powered by Jive Software

Wildfire 3.2 Beta and HTTP Binding Problem

Hi,

I have recently installed Wildfire 3.2 Beta on my computer without any problems.

I am very interested in getting the HTTP Binding working with any JS client but having no luck at all.

The closest I can get is using JSJaC Simple Client but I am getting the error message:

Couldn’'t connect. Please try again…

Code: 500

Type: wait

Condition: internal-service-error

At least it is contacting the server, but not sure why I would get this response.

The JSJaC client is running on the same domain as the Wildfire server.

I have also tried JWChat but am getting the following error:

(level 1) func: unknown

initial response broken (status: 405)

This is in the debug window. However with JWChat I am getting that error nomatter what server name I put in. This suggests that it isn’'t finding the Wildfire server at all.

Has anyone managed to get HTTP Binding to work with the latest release of Wildfire?

Your help is really appreciated.

Daniel

I have looked into this more and it seems Wildfire is simply returning the default html with a link to

the http bind protocol rather than the correct response. As can be seen below:

SENT:

RECEIVED:

****Wildfire HTTP Binding Service

Why is it doing that? Am I using the wrong http base? It is set to:

http://servername:8080

Is there a specific page I should be posting to? Can’'t find any documentation on this.

Thanks again.

You want http://servername:8080/http-bind/

Cheers,

Alex

I just found it also by looking at web.xml in spank, but really appreciate your help.

Thanks!

Daniel