Wildfire doesn''t start after a machine name change

Hi gang,

I’‘m having an issue with deployement of some Windows 2003 servers. I’‘m sending out about 30 new servers to branch offices and to ensure that each office gets the same server I’'m imaging them with a ghosting solution. Once each office recieves the server, a local administrator will change the name of the server. Once this happens Wildfire will not launch.

I’'m assuming Wildfire is writing the name of the machine to the database? Is there a way to bring Wildfire back online after its name has been changed?

Thanks in advance!


BTW: I’'m using MySQL 4.1 for the database.


as I don’‘t have a windows server I can’'t test it. As Wildfire usually binds to all available interfaces I wonder why it should fail - the name / xmpp.domain is stored in the database but it should not cause trouble.

Do you see errors in the log files?


I do have a set of errors in the log file. I’'ll grab a set tomorrow and post them. Thanks for the reply.

I ran into this same problem and after all troubleshooting steps the actual problem in my case was the hostname I was assigning. The WildFire server doesn’'t like underscores in the hostname. Once I eliminated the underscore everything worked fine with the new hostname. I am wondering if the naming restrictions resemble the same restrictions for pre-windows 2000 computers?


an underscore character is not allowed within DNS names, even if some servers support it. So it may cause an exception within Java.

RFC 952

A “name” (Net, Host, Gateway, or Domain name) is a text string up to 24 characters drawn from the alphabet (A-Z), digits (0-9), minus sign , and period (.).