powered by Jive Software

Wildfire on Debian PPC

Is it possible to run Wildfire under Debian PPC?

Here’‘s what I’'ve tried so far,

When starting Wildfire, it refuses to start with the error,

nohup: appending output to ‘‘nohup.out’’

The contents of nohup.out is the following,

JVMJ9VM007E Command-line option unrecognised: -server

Could not create the Java virtual machine.

If I remove the ‘’-server’’ from the Wildfire-script, the server starts, but I am unable to connect

to the admin console on port 9090.

There is no mention in any of the logs. The only entry is that Wildfire was successfully started.

I’‘m aware that the ‘’-server’’ problem is probably Java-related, but I would really like to know if it’'s at all possible to run Wildfire under Debian PPC?

BTW, I’'m using IBM Java SDK PPC 1.5

/ Peter

Hi Peter,

it seems that Wildfire does not run with IBM’'s 5.0 JVM. I tried this with AIX and linux FC4 and can confirm that it does not start up.

LG

Hi LG,

I’'ve looked at the requirements for Wildfire and it only lists Java 1.5, NOT specifically Sun…

Should this be reported as a bug and what would it take to get it running under IBM?

Could a developer please advise if this should be reported as a bug… thanks.

/ Peter

thanks.

Wildfire does not run under IBM’'s 5.0 JVM.

This has been confirmed on the following systems

  • Debian Sarge PPC

  • AIX

  • FC4

Could someone please report this as a bug?

Wildfire starts up normally (after removing Sun-centric ‘’-server’’ from startup-script),

but does not respond on port 9090.

There is nothing unusual in the logs.

Installing Sun 1.5 is not an option as it’'s not supported on PPC.

Thanks!

/ Peter

For what its worth, in OSX 10.4 you can now get “Sun” Java 1.5 and it works wonderful for Wildfire

Ofcourse you have to get it from Software Update, Sun does not distribute it.

~tommy

Wildfire on PPC works like a charm using IBM’'s JRE or JDK with Tomcat and the Wildfire WAR file.

Found a solution.

  • installed IBM’'s JRE 1.5

  • installed Wildfire

  • Removed all instances of ‘’-server’’ from the Wildfire script.

  • Changed ‘‘securePort’’ from 9091 to -1 in conf/wildfire.xml

I’'m now able to login at localhost:9090 and everything seems to work.

For some reason, the Wildfire admin interface does not like SSL under Debian PPC.

Here’'s a snippet from the error log,

2006.04.04 17:08:05

org.jivesoftware.wildfire.container.PluginManager.loadPlugin(PluginManager.java: 354) Error loading plugin

java.lang.NoClassDefFoundError: com.sun.net.ssl.internal.ssl.Provider

Thanks for the replies to this thread.

/ Schumacher

Other than SSL on the web interface, are there any other issues you stumbled on? I dont plan on running Wildfire in production on PPC, but I would like to use it on my PowerBook (Linux) for testing some things…

Nope, everything seems to work.