powered by Jive Software

Wildfire on SUSE Problems

I have been using Jive Messenger on Wintel platforms for several releases.

Installs and upgrades – including upgrade to MySQL database schema changes

– have always been superb.

I have been trying for three days to get going with Wildfire on SuSE with no

luck. During that time the release has gone from 2_4_3 to 2_4_4, so these

are obviously volatile times for you guys.

If I try to grab the .tar file, the server starts up, but as soon as

I get past the language selection, the browser-based configuration tool

dies apparently because jetty cannot be found. I assume that jetty is still

bundled somewhere in the set of files, or am I supposed to independently

grab some additional .jar file?

If I try to grab the .rpm file, YaST dies with an incomplete message that

seems to be saying that it cannot find the necessary package dependencies.

If I back off to Wintel, I can successfully bring up a clean/new installation –

I have not tried to upgrade from the 2.x.x. Messenger code that was installed

in October.

What is the recommended process for getting a clean/new install on

SuSE 10 – I think I successfully overcame the dependency on jre 1.5 –

SuSE 10.0 ships with 1.4.2. It looks like SuSE 10.1 beta may ship with

1.5.

Thank you.

Hi,

I usually use a local user and copy SUN’‘s JRE (jre-1_5_0_06-linux-i586.bin) and Jive’‘s Wildfire there, then I excute/extract these files there. I use my own start script, so I’'m sure which JVM is used, you may want to “export INSTALL4J_JAVA_HOME=$/jre-1_5_0_06” before running “./bin/wildfire”

Maybe you can try to install and run it this way?

LG

In /home/tcorbet you should have these files and directories:

jre-1_5_0_06-linux-i586.bin

wildfire.tar.gz

jre-1_5_0_06/

wildfire/

Thanks for the suggestions.

I followed them, but still was greeted with the same error message.

Not knowing precisely what is going on, I did look into the wildfire script

to see what INSTALL4J_JAVA_HOME was about. I then saw the comment

saying that INSTALL4J_JAVA_HOME_OVERRIDE might have some significance,

so I set that shell variable to the local JRE directory as well as the one you

suggested.

In all cases, the second screen from http://localhost:9090,

after accepting the default English language is:

HTTP ERROR: 500

mq: mq

RequestURI=/setup/setup-host-settings.jsp

Powered by Jetty://

mq is the host name as well as the name of the MySQL database,

but I cannot discern what the failure is. Where should the context path

reside after performing the dowload/extract/setups?

Thank you.

Hi,

the log files should be very short, are there any errors in them, maybe in nohup.out?

Does Wildfire open all ports (9090, 9091, 5222, 5223 and 5269 - use “netstat -an” to verify)?

Maybe you want to run “sh -x bin/wildfire start” instead of “bin/wildfire start”, this should output which java version is used.

Looking at “http://localhost:9090” and “mq: mq” I wonder if you may have a problem with /etc/hosts? Is the first line “127.0.0.1 mq” or “127.0.0.1 localhost” ? Or does http://mq:9090/ let’'s you configure Wildfire?

LG

The -x shell output is a little long, sorry, but maybe you will see something that I am not seeing.

I will push it to the end of this reply.

nohup.out is an empty file.

Info.log output looks like I think it should:

2006.01.27 14:48:40 Wildfire 2.4.4

2006.01.27 14:48:54 Admin console listening at:

http://127.0.0.1:9090

https://127.0.0.1:9091

At least that is what I was always accustomed to seeing when starting up the

Messenger on windows.

BTW: Even before attempting your good suggestions, I had gone through a lot of

hoops with suggestions on how to use the Debian ‘‘alternaties’’ facility to have Java .15

coexist with the 1.4.2 that is provided. That led me to completely uninstalling 1.4.2, so

no matter whether the path is /usr/java… or in my home, I don’'t think the problem has

to do with the ‘‘wrong JVM’’ being launched.

In my naivete, it appears that the JVM gets launched, and I now suspect that jetty is

really ok, but jetty, when it tries to redirect to whatever jsp/servlet it needs, is not finding

/setup/setup-host-settings.jsp

I tried ‘‘find’’ in the installation directory – no luck, but I guess I shouldn’'t have expected

to find it. It must be in a .jar file somewhere, but I haven’'t been able to find it there either.

===== truncated shell startup output =================

mq:/home/tcorbet/wildfire/bin # sh -x wildfire start

Starting wildfire

  • nohup /usr/java/jdk1.5.0_06/bin/java -server -Dinstall4j.jvmDir=/usr/java/jdk1.5.0_06 -Dinstall4j.appDir=/home/tcorbet/wildfire -Dexe4j.moduleName=/home/tcorbet/wildfire/bin/wildfire -classpath /home/tcorbet/wildfire/.install4j/i4jruntime.jar:/home/tcorbet/wildfire/lib/act ivation.jar:/home/tcorbet/wildfire/lib/bouncycastle.jar:/home/tcorbet/wildfire/l ib/commons-el.jar:/home/tcorbet/wildfire/lib/hsqldb.jar:/home/tcorbet/wildfire/l ib/hsqldbutil.jar:/home/tcorbet/wildfire/lib/jasper-compiler.jar:/home/tcorbet/w ildfire/lib/jasper-runtime.jar:/home/tcorbet/wildfire/lib/jdic.jar:/home/tcorbet /wildfire/lib/jtds.jar:/home/tcorbet/wildfire/lib/mail.jar:/home/tcorbet/wildfir e/lib/mysql.jar:/home/tcorbet/wildfire/lib/postgres.jar:/home/tcorbet/wildfire/l ib/servlet.jar:/home/tcorbet/wildfire/lib/startup.jar:/home/tcorbet/wildfire/lib /wildfire.jar com.install4j.runtime.Launcher start org.jivesoftware.wildfire.starter.ServerStarter false false /home/tcorbet/wildfire/bin/…/logs/stderror.log /home/tcorbet/wildfire/bin/…/logs/stdoutt.log true true false ‘’’’ true true 0 0 ‘’’’ 20 20 Arial 0,0,0 8 500 ‘‘version 2.4.4’’ 20 40 Arial 0,0,0 8 500 -1 -DwildfireHome=/home/tcorbet/wildfire -Dwildfire.lib.dir=/home/tcorbet/wildfire/lib start

nohup: appending output to `nohup.out’’

  • exit 0

Message was edited by:

tcorbet

Hi,

the interesting part of the shell output is the start command:

Starting wildfire

  • nohup /usr/java/jdk1.5.0_06/bin/java -server …[/i]

so you’'re using Java 5.

Maybe you want to edit your previous post and shorten it a bit.

Did you try using http://mq:9090/ instead of the localhost IP?

LG

  1. Ok, I shortened the shell startup output.

  2. Yes, the admin page comes up with the URL

set as http://mq.hq.sss.com:9090

but still fails the same when trying to get to the

host-settings jsp servlet.

  1. I tracked down the web.xml file that maps

the context to the actual servlet class.

  1. I confirmed that that actual servlet class

indeed is in the admin jar file.

  1. Netstat does not show activity concerning

port 5222, but it does show a listener for 9090.

  1. Both those ports are opened through the

NAT server that connects all of this – the same as

the settings were when it ran fine as Messenger

on W2K Advanced Server. But trying to move

the current Server to the SuSE box leaves me

with the HTTP 500 error and no way to continue

with the set up process that I can see.

Thanks for the help in working the issues.

Hi,

this sounds really weird. If you did install java also in your home directory you could try to start Wildfire like this - just to make sure that you did try a second jre installation:

nohup /home/tcorbet/jdk1.5.0_06/bin/java -server -Dinstall4j.jvmDir=/usr/java/jdk1.5.0_06 -Dinstall4j.appDir=/home/tcorbet/wildfire -Dexe4j.moduleName=/home/tcorbet/wildfire/bin/wildfire -classpath /home/tcorbet/wildfire/.install4j/i4jruntime.jar:/home/tcorbet/wildfire/lib/act ivation.jar:/home/tcorbet/wildfire/lib/bouncycastle.jar:/home/tcorbet/wildfire/l ib/commons-el.jar:/home/tcorbet/wildfire/lib/hsqldb.jar:/home/tcorbet/wildfire/l ib/hsqldbutil.jar:/home/tcorbet/wildfire/lib/jasper-compiler.jar:/home/tcorbet/w ildfire/lib/jasper-runtime.jar:/home/tcorbet/wildfire/lib/jdic.jar:/home/tcorbet /wildfire/lib/jtds.jar:/home/tcorbet/wildfire/lib/mail.jar:/home/tcorbet/wildfir e/lib/mysql.jar:/home/tcorbet/wildfire/lib/postgres.jar:/home/tcorbet/wildfire/l ib/servlet.jar:/home/tcorbet/wildfire/lib/startup.jar:/home/tcorbet/wildfire/lib /wildfire.jar com.install4j.runtime.Launcher start org.jivesoftware.wildfire.starter.ServerStarter false false /home/tcorbet/wildfire/bin/…/logs/stderror.log /home/tcorbet/wildfire/bin/…/logs/stdoutt.log true true false ‘’’’ true true 0 0 ‘’’’ 20 20 Arial 0,0,0 8 500 ‘‘version 2.4.4’’ 20 40 Arial 0,0,0 8 500 -1 -DwildfireHome=/home/tcorbet/wildfire -Dwildfire.lib.dir=/home/tcorbet/wildfire/lib start &

Do the files and directories have the right permissions (tcorbet:tcorbet)? Currently I have no other idea what the problem could be.

LG

LG,

Thanks for the suggestion. I had to get the systems back up for

production by Monday morning, so I just backed off to putting it

on a W2K server – the same way the previous releases of Messenger

had been running. It works fine.

I will try another SuSE test using the long command line you provided.

[It’'s hard to believe that all of that is a single invocation of java, but

thanks very much for the detailed facts.

Yes, when I tried to put everything in my own home directory –

the jre and wildfire, the permissions were wide open – 777-- for everything.

I’'m having the same problem, but on a GENTOO system:

funny enough when I do:

http://jabber:9090/setup/

It gives me a directory listing

with only a setup-style.css file (the setup-host-settings.jsp is not there, but also the index.html isn’'t either)???

funny enough when I do:

http://jabber:9090/setup/

It gives me a directory listing

with only a setup-style.css file (the

setup-host-settings.jsp is not there, but also the

index.html isn’'t either)???

it shows the same for me, but everything is working fine, i dont know how jsp is working, but maybe it’'s generating/unpacking on the fly, or maybe Jetty is hiding all the stuff

BTW, some JSP naming strangeness. System Properties are on server-properties.jsp