powered by Jive Software

Wildfire setup loop

Hello,

I set up the wildfire server successfully and was able to login. In the process of setting up authentication through LDAP I have run into a problem: when I try to login to the server WebUI it goes into a loop that keeps asking me what language, server settings, database settings, admin info (and it has the proper email address there). I have tried turning ldap off and using the passwords I set up and it still does the same thing. Any idea what might be causing this?

I have tried setting my and it keeps trying to login using the username admin.

btw, it is on a mac os x server, 10.4.6…if you need any more specific information please let me know and I will be happy to provide it.

Thanks,

Alex Morken

That usually means there is something in your wildfire.xml it doesn’'t like. Post your config (minus passwords) and we might be able to see the issue with you.

Jeff

Hi,

I could image that the wildifre.xml is read-only or your client does not accept cookies. Anyhow you can change the field in wildfire.xml from false to true and then it will no longer be displayed.

LG

below is the config file…

<–snip–>

Message was edited by: alx

My client does accept cookies - I have set it up before and it worked. It only quit working after ldap settings were set up. wildfire.xml has rw-rw-rw- permissions for testing at the moment and is still returning the same problem.

I will try the setup field…

thanks…

I had difficulty making sense out of yours. Here’'s mine. it is a working config. if you are not using postgresql, then you may only want to add the LDAP stuff.

Changing the setup field to false also yielded the same result as before…there was a longer pause this time, but it ended up in the same loop

try my file and also check the permissions that IT brought up. It should work for you.

Message was edited by: jeff_garner

Hi,

you may need to add ou= to the basedn like Jeff did.

LG

I tried adding the ou= and no luck.

Jeff,

I tried snipping out the ldap settings and editing them to my needs and I am still stuck in this loop. What is interesting to me is that even if I try to comment out the ldap settings it still throws me into this loop…

hrmmm…

Thanks for all of the help and responses so far, they are very appreciated.

-alex

Message was edited by: alx

Hi Alex,

I wonder if you see errors in the Wildfire log files. With setup=true this should not happen, and debug=true is also there, maybe a useful log entry there.

I could image that Wildfire is running two times, so maybe a killall or a reboot could make sure that this is not the case, I actually don’'t think that it helps but it makes sure that this is not the cause for the problem.

LG

Hello,

I have setup=false and debug=true. I will take a look in the logs. I checked if I had 2 copies of the application running and i did not.

thanks for the help…

alex

I love replying to myself!

anyway…

I copied the original version of wildfire.xml over, was able to login locally without ldap set up. I am now in the process of hooking into ldap and it is going much smoother. I just thought I would give you a heads up before you start typing anything else.

I really appreciate the quick and thoughtful responses.

-Alex Morken

King Cycle Group

I got it all working now. Thanks for the help. I think something just got a bit messed up and starting from fresh is what I need…so fresh and so clean!

thanks,

alex

I didn’'t really find a working fix for my problem other then starting from scratch and then it went pretty smoothly…

I rememer having this before aswell

problem was that my adminDN was not set up correctly and the authorisedUsernames still had admin in it, and nothing else…