Wildfire up, Xiff installed - what''s next?

I installed Wildfire on my Red Hat Fedora server and all is well with the Admin tool. I installed Xiff on my development box (XP) and copied the required class files as directed in the README. Opend the FLA file and published it and found it empty (of course!).

What I didn’‘t find in the examples’’ ActionScript was any fruther direction on where to set the connection address, only the username and password. Not much on wht those mean either or how to get the example in Xiff to connect to my server. Could someone point me to this infoor tell me how to get up and running? Thanks.

Real nooby booby.

The examples that come with an older version of xiff are good for getting started

var connection = new XMPPConnection();

connection.username = “jive”;

connection.password = “demo”;

connection.server = “jivesoftware.org”;


Thanks astrocrack, yeah my example was missing the “connection.connect(“flash”);” line. Now, another question - I got “XIFFIAN” and tried that. He said the SWF file has to be on the same box as the Wildfire server - no problem, put it over there and Bang! - it connects to his server. But when I type my server’‘s username, password and URL in through his PHP page, it doesn’'t connect. I suspect a problem in the port assignment. In his PHP script the port is set to 5222 but Wildfire on my box is running on 9091. I tried hard-wiring it in the PHP script to no avail. Does the port just default or do I have to specifiy it? Is this the problem anyway? So many variables, eh? B^)

I’'d like to have an example up and running by EOB today for a meeting with my client tomorrow. Thanks again for your help.

Message was edited by: bobkatzz

You can change the default port with the property connection.port otherwise it will try to reach 5222. You can always figure out the properties and methods of each class in Xiff documentation.

yep-PER! that did it! Thanks - buy yourself a beer, on me! B^)

OOps - did you finish that beer yet? Um . . . when it worked it was running resident on my dev box (XP) but when I uploaded it to the server (Linux) it now doesn’'t work again. (??). Double or nuthin - a beer and a shot?

pre-thanks again. RT

well I think you need the crossdomain.xml in the server.

Create a “crossdomain.xml” file with the following code;

<?xml version="1.0"?>

( wildcard just for testing)

Place the file in the directory where you have the server hosted. Try searching the forum for other crossdomain.xml files because you may need more options like the port or something like that.

cheer. thx for the drinks ;D

OK. I thought that the crossdomain was only necessary if the swf was NOT on the same server. But, as you mentioned, there may be other issues. I will find out and post.

Drink Up! B^)

I had both on the same server too and needed the crossdomain file. hopefully it will work

Welp - I’‘ve jumped through about every crossdomain.xml hoop out there and it’'s still not running on my server. Some good news is that I made two copies of the example (one for a user “goofy” and one for a user “flashy”) and I can run them off my desk top and SHAZZAM! They talk to each other! But, alas, not on my server. Here are the contents of the crossdomain.xml::

<?xml version="1.0"?>

However, I have no way to know if the Flash file is actually loading it. Hrmmmm!

(I need a drink!) B^)~

have you tried something like this?

<?xml version="1.0"?>

Hey thanks for the response - I was out of it (in the physical world ) for a day. I determined that, in fact, Wildfire is ported to 5222 so that was not a problem and, yes, my crossdomain.xml looks exactly like all the hundreds of other examples that I’‘ve seen out there. Maybe it’‘s where I’‘m putting it? So I put it in every root folder of every domain on my server (just for good measure hehe) and it still dain’‘t voikin’’. Ah the indescribably delicious pain of stupidity. B^)

Tea of the Day - Rishi Tea’'s “Citron OOlong” mmmmmm nummer tuffies!!

any luck? i’'m in the same position. crossdomain is all set, the app works locally, but natta when i run off of the web server. does there need to be a crossdomain file on the wildfire server as well? (the client is being hosted off of a different webserver)

Try calling the loadPolicyFile method: