powered by Jive Software

WildFire v3.2.0 server IP setting issue

Here’'s a snippet from the Server Properties WiFi v3.1.1:

Server Ports

1: IP:Port, Security: 10.0.219.128:5222, NORMAL

Domain Name(s): gigahertz.org.yu

2: IP:Port, Security: 10.0.219.128:5223, TLS (SSL)

Domain Name(s): gigahertz.org.yu

How come there’'s no IP setting in WiFi v3.2.0? Some internal server/router/DNS issues prevent me from delpoying the server with just gigahertz.org.yu domain name. Is there a way to add a new property to set the IP in the System Properties menu?

Thank you in advance!

YZ7REA Vladimir

4N7ATV Repeater Administrator

YU7GHZ Radio Club President

Hey Vladimir,

While running the setup process you can specify the domain to be used by Wildfire. By default, the server will listen on all network interfaces on port 5222 and 5223 (besides 9090, 9091, 5269, etc.). The domain that you specify to be hosted by Wildfire should be added to a DNS server as a SRV record. Clients and remote servers trying to connect to your server will do a DNS SRV look up to get the IP address behind the domain you are using. It is also possible to use the IP address of the machine as your domain although that will make it harder if you ever move your Wildfire server to some other machine. Moreover, you can also instruct Wildfire to listen on a given interface instead of all interfaces. Set the system property network.interface with your decided interface and restart the server.

Regards,

– Gato

Thank you very much for the swift reply. As I said before, due to some network issues I could not instruct our DNS to resolve gigahertz.org.yu to the server’‘s IP address. I have found a workaround by instructing the xmpp clients to connect directly to the server’'s IP (Connection Settings in Pandion)

Best regs,

Vlad