powered by Jive Software

Windows Install buggy (2.5.8 & 2.6.0beta)

Hi,

after a fresh install of Spark 2.5.8 it was impossible to voice chat. Reconnecting mike, rebooting, reinstalling, nothing helped.

Starting via startup.bat there was a

java.lang.NoClassDefFoundError: mil/jfcom/cie/media/session/MediaSessionListener

Searching for the appropriate class we found the class in the Speex.jar inside %SPARK_HOME%\plugins\jingle.jar in the lib directory.

Moving that to %SPARK_HOME%\jre\lib\ext solved the issue.

The problem seems to be in the 2.6.0 beta1 installer as well, but not in the Mac version. Interesting enough two colleagues had no problem: They had installed an older version of Spark and installing the new one in the same directory.

And two other issues concerning the buggy windows install: The file bin/startup.bat is unix-like with slashes and doesn’t explicitly use the co-installed JRE (java.exe).

We’d be happy to see this solved as Spark seems great.

weitsecR

I too have had some issues with 2.5.8, but with respect to plugins.

I am currently using 2.5.8 (upgraded a number of times over the life of use) and had installed and was using the OSSPhone plugin from opensourcesip.org. I tried 2.6.0 beta but downgraded back to 2.5.8, after which I tried to install a plugin. For some reason the plugin wouldn’t load (it looks like the jar wouldn’t automatically expand). I uninstalled 2.5.8 and deleted the directory entirely so that it was like a fresh install.

Even after the fresh install of 2.5.8, the spark plugins would not start. Even OSSPhone that I know was working with 2.5.8 before the upgrade to 2.6.0 beta

I downgraded to 2.5.0 and the plugin magically worked. I have upgraded incrementally 2.5.5, 2.5.6, 2.5.7 and I found that the plugin is working with 2.5.6 but then stop working with 2.5.7 and 2.5.8.

I might normally suspect the plugin, however it was working with 2.5.8 before I tried the 2.6.0 beta. Because I uninstalled spark, deleted the folder, and reinstalled from scratch, I would suspect that all was OK, but alas no.

Does anyone have any ideas? I have had to downgrade but 2.5.6 has a bug that disappears from the system tray when minimized (but is still running). I would like to get back to 2.5.8 but am finally at a loss. Is there potentially some registry entries that I need to remove? Any help would be appreciated.

thanx for this too old post man lol