powered by Jive Software

Windows Migration of Openfire

I would like to move my current windows install of openfire to another windows box. I am currently running version 3.8.1 on a windows xp box and want to move to a windows 7 x32 box. What is the best way to get this done?

Depends on what DB you are using.

I am using the embedded DB that comes with openfire. Also it is intergrated with AD.

The easiest way would be to install fresh Openfire on new server, then copy and overwrite its installation folder with content of the C:\Program Files\Openfire from the old installation.

I just tried your suggestion. This is what happens…The system pegs at 100% and after 5 minutes I get this error:

Exception in thread “HSQLDB Timer @2a5330” java.lang.OutOfMemoryError: Java heap space

Out of memory error. Weird. Ok, you can try a slightly different way, though i think it should be the same. Reinstall Openfire on new server (clean install, btw, how you tried running new Openfire on this new server to see if it launches ok and runs, well at least with only the admin user?).

Then copy Openfire\conf\openfire.xml, Openfire\embedded-db, and if you use SSL Openfire\resources\security\ from the old installation to the same places in the new installation, overwriting. Also, make sure new installation isn’t running while copying.

Hi Wroot,

I think I figured it out. Here is what I did. After trying what you suggested I got the same results. The system hung like before. So this is what seemed to work for me…

I uninstalled and deleted the openfire directory from the new server. I copied the entire openfire directory from the old server and then ran the command to install openfire as a service on the new server. Started the service and was able to login with no issues. Then with openfire running I ran the openfire installer. Installer ran fin, Started the openfire service…wait a few minutes and was able to login and all seems good. I am going to some testing tomorrow to make sure it’s working. Thank you for you advice and help on this.

So, you were using service on the old server? That’s may be th case. Maybe your copied installation were searching for the service and couldn’t find it until you installed it.