powered by Jive Software

Windows user manager hangs when Spark is running

When the Spark client is running, our adminsitrators cannot run their Windows user manager software. It hangs and doesn’‘t repaint it’'s screen until the Spark client is shutdown. Once Spark is closed, the user manager works immediately.

I can post more details tomorrow but I wanted to get this out there incase someone else encountered it and knows of the issue.

Hi Tatera,

What are the reproducable steps for this one? I don’‘t think I’'m using the right Windows user manager

Thanks,

Derek

We’'ve done a little poking around with it and found a pattern. The problem can be reproduced by launching the Spark client, then launching the Windows User Manager version 5.1 using the “Run As” context under a different user.

We tried running both the user manager and Spark under the same conext and the computer locked.

If the manager and spark are executed without a “run as” context, they both run normally.

I hope that helps.

I am having a similar issue but with a printer.

Spark 1.0.0

OS - XP Pro

Printer - Canon BJC - 85

Normally when I print using this printer I get a pop up box telling me that I do not have a color cartridge installed and would I like to replace it or ignore it. I click ignore and it prints away.

However when I have Spark running and I print I get the pop up box but often it does not complete painting and even if it does then it hangs. I am unable to click on any of the buttons. When I exit Spark the pop up finishes loading and I can complete printing.

I have yet to try this with other printers which I will do in the morning.

I am trialing Spark along with Asterisk-IM with a view to rolling it out to 450 Computer Troubleshooter Franchises worldwide.

Apart from this little glitch I am very impressed and the trial is going very well.

Cheers,

Jon

Hi Jon,

I’'m wondering if my native calls are doing this somehow. Would you be interested in helping me out with testing our daily builds? We use Java Web Start for this and it would help me out tremendously.

Cheers,

Derek

This is kind of odd as I have a user who is having this same issue. I am testing Jive and Spark on our network here to replace my old jabber server and have had no problems until today. I have a user who is having the same issue. They are using Active Directory Users and Computers fine. They start the Spark client and the AD Users and Computer windows freeze. Once he closes out the Spark client, the AD windows return.

Any fix for this would be great and testing the daily build is fine with me also.

Thank you,

Troy

Derek,

I will be glad to help out. I don’'t know the first thing about Java, apart from the fact it tastes good first thing in the morning, so be gentle with me.

Jon

I just tried to recreate this problem with Spark and ADUC. I am having no problems like the one you described.

I tried opening Spark first, then opening ADUC first, nothing. No problems.

It is funny you mention that.

After I posted that, I tested it myself and can run AD Users and Computers without it locking up. But, if you do a “run as” and start the client with a differnet user name, it does lock up. It does not matter if you have Spark running before or after you start AD U&C’'s either. The AD U&C window locks up until you close out Spark.

Troy

Interesting. So it seems the “run as” is the one thing everyone has in common. I will take a look at this, but honestly don’'t know what this could be. Anyone have any ideas?

-Derek

I have just tried running Spark as another user with admin rights and the PC locks up. Spark was using 100% of CPU resources.

Jon

After much research, it seems this is caused by system callbacks in a multiuser environment. So, I’'m in the process of trying to get a good fix in, but if anyone is interested in trying out the daily builds, I will continue to try to get this fixed before the 1.0.2 release. You will need JDK 1.5 for this one (www.java.com), but give it a shot. It also has large performance improvements as well.

Web Start: http://liveassist.jivesoftware.com/im/app/spark.jnlp

I have been trying your daily builds but still having the problem listed above. Just thought you might like to know since no one seems to have replied to this post since you posted the daily build link.

Troy

I just tried it since the latest release and I’‘m not having the same issue. I will test it on a few other workstations before I say it’'s fixed for sure.