powered by Jive Software

XML Debugger Plugin not working 3.9.1

Hi all,

i have installed the Openfire Server 3.9.1 from scratch and tried to run the XMLdebugger plugin. I can’t get it started. The server does not create any stdout.log or stderror.log etc files.

That’s the ouput of the info.log

02.09 13:33:29 org.jivesoftware.openfire.container.PluginClassLoader - Unloading plugin JAR file /opt/openfire/plugins/xmldebugger/lib/plugin-xmldebugger-jspc.jar

2014.02.09 13:33:29 org.jivesoftware.openfire.container.PluginClassLoader - Unloading plugin JAR file /opt/openfire/plugins/xmldebugger/lib/plugin-xmldebugger.jar

I also updated a running Openfire version from 3.8.1 to 3.9.1. Then i get the Message “Ignoring plugin xmldebugger: requires server version 3.9.0” inside of the stdout.log"

I have deleted the entries in the System properties but no luck.

Does any one know what to do? This plugin is very important for me because im developing an application and without this plugin i am very helpless. i dont want to run to different openfire enviroments(Server,database,etc)

Thanks for your help.

django

I’ve seen some reports with plugins loading after people upgraded their servers to 3.9.0, then 3.9.1. I have no problem on Windows 7 with the embedded database (upgraded from 3.8.2 to 3.9.1). Maybe it’s linux related. What distro are you on? Also 64-bit?

As i said, it looks it runs ok on my server, though it only prints out traffic to Launcher console. I can’t find a file where it prints also. There is no stdout log file and stderr is empty. Readme doesn’t say it clearly, so i’m not sure how it should work.

Hello wroot,

sorry for the late response.

The problem solved itself. Openfire started to write the logs to the nohop.out instead of stderror.log etc.

I reinstalled the system new with ubuntu (previous Suse). Had a little problem with the logs under Ubuntu, but a forum post solved my problem.

Thanks for your help!