powered by Jive Software

XML-RPC Registration Problem

Hey folks -

I’'m building a system that requires the ability to register openfire accounts on the fly… but when it comes to the use of the gateway plugin, well, redstone throws an redstone.xmlrpc.XmlRpcException with a message prior to the exception, “White spaces are required between publicId and systemId.”.

Now, I investigated the issue, and it appears that the openfire UI is requiring that the caller log in to the admin UI page prior to the request being completed - and the login page has a bunch of space (and obviously no XML doctype declaration) at the top of the page.

Now, I think that I’'ve followed all of the instructions on how to do this from the readme, and manual testing of the plugin URI does in fact redirect to the login page… is this a bug, or did I miss a step?

Any help would me most certainly appreciated - great work thus far!

Thanks,

Cash

Hrm. There’'s a directive:

AuthCheckFilter.addExclude(“gateway/xml-rpc”);

that tells the auth check functionality to ignore this plugin. What’'s the exact url you are using?

Hmm, ok - the url that I used was http://<server.domain>:9090/plugins/gateway/xmlrpc

Where would I set this parameter?

Thanks for your help!

Cash

Try xml-rpc instead of xmlrpc =)

Consider it tried… no joy

What version are you using? The latest release doesn’'t include xml-rpc support. 1.1.0 Beta 3 does though.

I’‘m using 1.0.2… which would explain why it’'s not working… I should have caught that.

Thanks for your help, and keep up the good work!

-Cash

Well I’‘m not sure I actually documented anywhere that it only showed up in 1.1.0. =D (aside from changelogs) I’‘m aiming to beef up my documentation but I’‘m holding steady at the moment because igniterealtime is moving to a new backend a some point and I didn’'t see the point in writing up big docs yet in case I end up having to redo them later. =)

hmm… well, let’'s see here -

I pulled out the “stable” jar and installed the beta (1.1.0 beta2), and using the url,

http://stan:9090/plugins/gateway/xml-rpc

… as well as …

http://stan:9090/plugins/gateway/xmlrpc

… I still end up getting the login page.

You mentioned a property modification earlier - is that something that I need to do, and if so, where?

-Cash

You know, I should pay more attention to what you wrote - I’'ll find beta 3 and install that.

Sorry about that

-Cash

Ok, so yeah… I can’‘t seem to find beta 3 - svn doesn’'t show a 1.1.0 beta 3?

Can you please point me to it?

Thanks,

-Cash

Ok, so I’'m retarded - nevermind, I found it.

I really should look in more obvious places for things like that - sorry

-Cash

=) No worries. I never got up with the Jive folk about posting the beta to the “beta plugins” page. dooh!