powered by Jive Software

Xmpp.client.idle is not working

Hi

I am using openfire version 3.4.5 and using system.client.idle equal to 60000 to kick out idle users after one minute but it is not working properly.

I used a normal client, connected to the server and pulled out my network cable from the computer but user is still appearing in session tab(even after 5 hrs) and also restarting the openfire did not remove them.

Please help.

Thanks.

Hi ranks,

In case u are using http connections, try with the property “xmpp.httpbind.client.idle”.

you can use it as System properties. Its argument is seconds. Hope this helps.

—monk

thanks Monk but this is not working.

Now I am using version 3.5.0 and if I use xmpp.client.idle equal to 30000 it works but setting the value higher than this doesn’t work.

Hey

Now I observed one more thing If I set xmpp.client.idle property and then I try to get the presence(multiUserChat.getOccupantPresence(userJid)) of logged in users in conference then It gives the presence null. If I do not set this property then it gives the presence.

can anyone help me please.

Thanks

Hi there I am having the same issue with the xmpp client idle and the xmpp client session timeout as well. Anything i set there does not work. I would also like to know if the values are in milliseconds. Anyone managed to sort this out. I am using 3.6.3 and the user never gets kick out. I first tried it with a normal client and thought that maybe it is pinging it constantly. So i unplugged the cable and the user is still active in the admin console…Any help would b appreciated.