powered by Jive Software

XMPP Clients cannot see openldap users


#1

Hi,

I was able to successfully bind to ldap from within the openfire admin interface. All users are listed and everything looks great from within the admin UI. Now when I get my IM client (PIdgin) to talk to the server I am not able to see any of the ldap users. Even adding specific users to my buddy list does not help. The buddy list show’s “Not Authorized” at all times. The other user doesn’t even receive an authorization request. What am I doing wrong or what am I missing? In the admin interface I am able to see the “green” user icons that implies that the server can see me logged in. I am using Openfire 3.7.1.

Any help would be greatly appreciated.

Thanks,

Shane


#2

I think that you have to create a group, and add all shared users in it.


#3

Hi Milan,

Groups can only be added if I am not using LDAP. When I first setup openfire via the admin UI. It asks for the basedn and other such things. It also ends up picking up all users as groups in addition to some groups that are listed in the basedn because every user has a cn as do the groups. Groups cannot be added since openfire uses LDAP as read only.

Thanks,

Shane


#4

Well,

1st. Do You have groups listed inside Admin panel?

2nd. As I remember there is a check box inside group settings that read “Share group” or something similar. You have to check it if you are not member of that group.

Please take a look here:


#5

Was anyboody able to figure out anything regarding this?