powered by Jive Software

XMPP over VPN using Openfire

Hi

I have installed OpenFire on an Ubuntu Server, and the users on LAN using Pidgin as a XMPP clients have no problems.

However, there are two locations connected with VPN (not a VPN client installed on the computer, firewall-to-firewall VPN) and some of them have problems connecting, someone have not. I have also tried another XMPP client, but also unstable. What happens is that it looks like it’s connected and “available”. There is contact there, because if I use wrong password it tell’s me that. But after about 1 minute, it says ping timeout.

I don’t have any problem with other protocols over this VPN connections, based on Sonicwall firewalls.

I hope someone could help me out with this problem.

regards

Xiglet

Just tried the Spark client, but still not able to connect to Openfire.

In my opinion, your firewall is blocking the client to receive the ping packets or blocking the server to send responses.

I don’t think so. There are other users behind the same firewall that do not experience these problems. Also, I know for sure that there is no restrictions between the VPN locations .

Frode