powered by Jive Software

Yahoo/jabber sais wrong password...just that it is correct

New day…new strange error sigh

I used 3.4.1 /w 1.2.0 and received a “password incorrect” with yahoo this morning for all our users (namely 2). Password is correct, weblogin at yahoo.com works. Nothing strange. Reboot, cache clearing, deactivating the transport, deleting the account in the backend…nothing solved the problem so I thought what the heck…try 3.4.2.

After installing 3.4.2 and GW 1.2.1 problem persists BUT now I also have the exactly same with jabber…what rules out a failure of yahoo itself.

No errors, warnings, just a debug Message that looks perfectly normal to me for a wrong password…just that it is correct. Oh. No special characters used in my passwords…just letters and numbers.

Next thing after a little bit of cursing (and a good meal) is probably wireshark to see what the little devil is actually sending to yahoo/jabber.

2007.12.11 12:33:50 Received iq packet: <iq id="LInyC-114" to="xmpp.jab" type="get" from="jts@jab/spark"><query xmlns="http://jabber.org/protocol/disco#info"></query></iq>
2007.12.11 12:33:50 xmpp: Sending packet: <iq type="result" id="LInyC-114" from="xmpp.jab" to="jts@jab/spark"><query xmlns="http://jabber.org/protocol/disco#info"><identity category="gateway" type="xmpp" name="XMPP Transport"></identity><feature var="http://jabber.org/protocol/disco#info"></feature><feature var="http://jabber.org/protocol/disco#items"></feature><feature var="jabber:iq:gateway"></feature><feature var="jabber:iq:register"></feature><feature var="jabber:iq:version"></feature><feature var="vcard-temp"></feature><feature var="jabber:iq:registered"></feature></query></iq>
2007.12.11 12:33:51 Received presence packet: <presence id="LInyC-115" to="xmpp.jab" from="jts@jab/spark"></presence>
2007.12.11 12:33:51 A new session has come online: jts@jab/spark
2007.12.11 12:33:51 Created xmpp session for jts@jab/spark as 'j@jabber.ccc.de'
2007.12.11 12:33:51 Creating xmpp session for j@jabber.ccc.de
2007.12.11 12:33:51 xmpp user's login/password does not appear to be correct: j@jabber.ccc.de
not-acceptable(406) Not Acceptable
at org.jivesoftware.smack.NonSASLAuthentication.authenticate(NonSASLAuthentication.java:78)
at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:443)
at org.jivesoftware.openfire.gateway.protocols.xmpp.XMPPSession$1.run(XMPPSession.java:172)
2007.12.11 12:33:51 Disconnecting session jts@jab from xmpp.jab
2007.12.11 12:33:52 xmpp: Sending packet: <presence type="unavailable" to="jts@jab" from="xmpp.jab"></presence>
2007.12.11 12:33:52 xmpp: Sending packet: <message type="error" from="xmpp.jab" to="jts@jab/spark"><body>The password you registered with is incorrect. Please re-register with the correct password.</body></message>

Additional Note: MSN and ICQ GW works.

Same problem here.

And yes, MSN and others seem to work fine … or rather as they were before.

I have the same error as well. All gateways work but Yahoo. It say i am using an invalid password.

We are also experiencing the same problems. Yahoo cannot authenticate properly. We did some research and found a similar thread over at http://trillian.cc/forums/showthread.php?t=89704. It appears that Trillian users also cannot log in properly.

Ditto.

Oddly enough it worked fine yesterday. I didn’t change anything.

Good lord… sounds like they tweaked the protocol. I’ll get in touch with the OpenYMSG team and aim to put out an ‘emergency release’ this week. =/

What fun! SAME HERE in gloomy Dayton, OH (Jabber 3.3.1)!

Yahoo seems to have made a change to their server code indeed. This, combined with buggy legacy code, introduced this problem. I’m tracking it as YMSG-20.

A patch for the problem has been applied to trunk. As trunk currently includes other code that’s still a work-in-progress, I patched an old revision of OpenYMSG code as well, which has been sent to Daniel.

Folk, thanks to the OpenYMSG team, this is fixed. I’m working out the process of releasing 1.2.1a, but for now, I’ve attached both the plugin and the repaired library. Those not running 1.2.1 may be able to simply replace the library in their plugin directory. I know this will work with 1.2.0. I do not know about 1.1.. Those who want to try it with 1.1., I would recommend copying the existing openymsg.jar out of the way and putting the new one in place. After replacing the library, reload the plugin from the admin console or restart your server. The process would go something like this:

  1. cd MY_OPENFIRE_HOME/plugins/gateway/lib

  2. mv openymsg.jar SOMEWHERE_ELSE, not in the lib directory

  3. copy attached openymsg.jar into same location (i would recommend you call it openymsg.jar, though I don’t think it matters)

  4. reload plugin/restart server

If you are running Openfire 3.4.2, simply install the 1.2.1a version of the plugin which has the fix. It’ll also be available for download off of the plugins page/through automatic update shortly.

Ok… gateway.jar will not be attached. It’s apparently too large. Crap. I’ll get it up on the plugins page shortly. Attached is the openymsg.jar though.
openymsg_0.1.jar (125534 Bytes)

The fix file does work with gateway plugin v1.2.1.

Works fine with 1.2.0

Thank you guys for the quick fix!

A note for the patchers (at least with *nix): Make sure the user that runs Openfire has no rights to delete the openymsg.jar. Otherwise the reload of the plugin simply deletes it and installs its former (nonworking) file.

Still, XMPP connection is causing the upper error with 1.2.1. This does not happen with 1.2.0. (I downgraded, now it works again)


Update:

I might have found what causes the issue with XMPP

Analyzing with wireshark leads me to the following:

1.2.0 sends

first one leads to the request for the digest and a connection

second one leads to an 406 “not acceptable”.

Hrm. Lovely. If I do it one way, it seems to break for some servers. If I do it another way it breaks for other servers. facepalm What is jabber.ccc.de running btw?

Hi

I can report that the new jar also seems to work with 1.1 (I must upgrade!) . The issue caused me some consternation as I had just reinstalled my server late last night. I thought it was my fault until I caught up with this thread.

Thanks for the speedy update - as always.

According to their homepage they use:

jabberd1.4 Version 1.6

Still, much more problematic for me is that I still cannot manage to add anyone with my transports as requests for authorization are not delivered in any direction and I still have not a single clue why…when that is solved…I could start raising the users to more that 2 :stuck_out_tongue:

Do you need a betatester? I think I stumble over every possible strange error there is :stuck_out_tongue: I’m just not good at solving them… I rendered my Openfire unusable (sometimes only nearly) with I think every update…and I’m testing since 3.0 I think…I’m really afraid to start using it in a productive environment…probably not without 4 setup and running Backupsystems :D. Maybe it does not like my Linux Gentoo VM. Should I consider BSD for even more fun?

Are you using an official Sun JVM? What version?

That actually could be causing a lot of this! I recall that there was even one version of the 1.5 JRE series that fixed some issues with Openfire and the IM Gateway on and off. I’m not sure what the minimum required version is though. 1.6 is generally considered the best.

at the moment I use a Sun VM 1.6 if I remember correctly (I’m not at work to take a look). But I’ll try if it changes if I use one of the older ones or patch the VM to the most recent Gentoo got in the not-so-stable repository. Thanks for the tip. Even more thanks if it changes something.

Might explain why some of my problems where gone when I compiled the stuff myself instead of just using the bins you provide.

I have inadvertedly installed 1.2.1a on a 3.4.1 system and the IMG has completely disappeared. I would like to revert to 1.2.0 and am looking for that partucular jar but I cannot seem to find it anywhere. Can anyone point me in the right direction?


Nevermind.  I just upgraded to 3.4.2 instead. Many thanks to Jadestorm for such a timely update!

Message was edited by: TheAngryPenguin

Please note that I’ve got feedback of users that report new problems. This indicates that Yahoo is still busy changing their network code.

Those changes do not seem persistent at this time, as currently, I’m not having any problems connecting to Yahoo. I won’t be surprised though if new problems surface in the next few days.

According to Meebo (an Online Mulitmessenger)

" It looks like Yahoo’s network is having a few

connection issues today. It appears to be on Yahoo’s server side.

They’re aware and I’m sure are working on the issue."

Sounds not too serious but I don’t know their source of information, so I don’t know if this really is just a regular “something doesn’t work like it should” or a “we don’t know whats happening so we just write something nice”

The Yahoo servers do not seem to be unresponsive - they do have periods in which they send out different things as what they used to. What seems to be going on is that Yahoo temporarily activates a bit of new code now and then. This causes login failures on clients based on old code. After some time, Yahoo disables the new login authentication again (I guess they are testing stuff). This causes the older / third party clients to be able to login again.

I’d not call these ‘outages’, especially since the regular Yahoo client is able to logon as usual during those periods.