powered by Jive Software

Yahoo transport problem!

Hi there to everyone here,

I am having a problem with the yahoo transport. when i try to logon to the gateway my yahoo transport will be automatic offline after 5 min but my msn transport is still there and kicking anyone encounter this problem is there a keep alive for yahoo transport that i can set ??? My version of IM Gateway is 1.2.1 Thanks for the help

As far as I know, there should not be a need for you to do manual ‘keep-alives’. The Yahoo library does perform a keep-alive, which pings the server every 20 minutes.

Does your problem occur in 5 minutes after logging in, or in 5 minutes after you sent your last message to the network? If you’re unsure, could you try to:

  1. Login

  2. Wait for 4 minutes

  3. (verify that you’re still logged on)

  4. Send a message to one of your Yahoo friends.

  5. Wait for the problem to re-occur.

It would be interesting to see if the problem occurs after one minute, after five minutes or not at all.

Hi there , i have try your method the disconnect will occur after 5 min of idle from the last message you try to send.

Thanks alot.

I’ve encountered the same problem too, after being idle for a few mintues, my yahoo account appears online in the wildfire gateway console, but I can’t send any messages. Friends on the yahoo client see me as offline.

I’ve done a debug log and found the following stacktrace, not sure if this is the cause of it:

error on process packet

java.net.SocketException: Connection reset

at java.net.SocketInputStream.read(SocketInputStream.java:168)

at java.io.BufferedInputStream.fill(BufferedInputStream.java:218)

at java.io.BufferedInputStream.read1(BufferedInputStream.java:256)

at java.io.BufferedInputStream.read(BufferedInputStream.java:313)

at org.openymsg.network.YMSG9InputStream.readBuffer(Unknown Source)

at org.openymsg.network.YMSG9InputStream.readPacket(Unknown Source)

at org.openymsg.network.DirectConnectionHandler.receivePacket(Unknown Source)

at org.openymsg.network.InputThread.run(Unknown Source)

Input error from yahoo: Source: InputThread

java.net.SocketException: Connection reset

at java.net.SocketInputStream.read(SocketInputStream.java:168)

at java.io.BufferedInputStream.fill(BufferedInputStream.java:218)

at java.io.BufferedInputStream.read1(BufferedInputStream.java:256)

at java.io.BufferedInputStream.read(BufferedInputStream.java:313)

at org.openymsg.network.YMSG9InputStream.readBuffer(Unknown Source)

at org.openymsg.network.YMSG9InputStream.readPacket(Unknown Source)

at org.openymsg.network.DirectConnectionHandler.receivePacket(Unknown Source)

at org.openymsg.network.InputThread.run(Unknown Source)

After that, any further attempts to send messages via the yahoo gateway will result in this in the debug log:

Received message packet: <message to=“xxx@yahoo.yyy” type=“chat” from=“aaa@yyy”><body>ccc</body></message>

Failed to send message to yahoo user.

Any ideas? Thanks in advance.

Hmm, maybe Yahoo changed the interval in which pings are expected. I’ll be tracking this issue as YMSG-22.

HI there i have try uploaded the version 1.2.2a into my open fire but i m still getting the disconection after 5 mins for yahoo transport but the connection for jabber and msn is still working ??