powered by Jive Software

Yet another MySQL connection question

This is really bugging me. My boss wants me to use Linux for our production Jabber server. Fine. I’‘ve got MySql 4.1 installed, and the table structure is created (I can see all this through webmin). When I try to get the Jive Messenger to connect to it, it keeps telling me its not possible. I’‘ve even tried connecting as ‘‘root’’ and that won’'t work either.

Eariler, I couldn’'t even start Jive Messenger, as it was complaining about ‘‘messangerHome’’ not defined.

If I do this under Windows with MySQL everything works great.

I know this topic has been done to death, but I didn’‘t find anything in the forums that looks like something I didn’'t try.

I’'m using Mandriva 2005 LE.

Could you try running:

mysql -u -p

on the same computer that your trying to run Jive Messenger on?

That works.

I’'m running MySql 4.1.11.

If I run:

PROMPT>mysql -u jabber -h localhost Jive230 -p

and enter the password, I get the proper prompt

Now when I run the setup, I get the error about ‘‘messangerHome’’ not defined. The system randomly allows me to get into the configuration system.

Yay Linux! :stuck_out_tongue:

Are you always running JM from it’'s bin directory?

i.e.

cd /path_to_JM/bin

./messenger start

Correct.

I haven’'t attempted to install it as a ‘‘service’’ yet.

I cd to: /opt/jive_messenger/bin

and execute: ./messenger start

and randomly, I get a message that ‘‘messengerHome’’ isn’'t defined.

I was shocked when I actually got the web configurator to start, as it hand’'t previously.

I had this problem under 2.3.0 and 2.2.x as well.

I’‘m not sure what the problem is, but I’‘m definately willing to point the finger at myself. It’‘s possible I’'ve just done something stupid.

I’‘m not quite sure what to do from here, but if you’‘d like to bounce ideas off of a Mandriva 2006.0 user that’'s running JM, feel free to add me to your roster (details in my profile).

It’‘s so strange. I can connect to the database with the provided tools & execute queries, but can’'t seem to get the Jive Messenger to talk to it.

I’'m going to see if maybe there is an updated JDBC driver. Perhaps that might fix it.

Not sure why this is, but I think I’'ve found out what triggers the ‘‘messengerHome’’ not being found.

If I run the application from my account (admsjc), I get the error.

If I do an ‘‘su’’ and then start the messenger, I can get into the configuration utility.

I still can’‘t connect to my database at all. I’'ve tried as both ‘‘root’’ & my ‘‘jabber’’ account.

By default, MySQL doesn’'t allow connections using TCP/IP. Can you make sure that permissions are set to allow this?

Regards,

Matt

That could be it. JM uses TCP to connect to MySQL, regardless of the host. mysql can use TCP, sockets, pipes, and memory.

If Matt is right, then this shouldn’'t work:

mysql -u jabber -h localhost --protocol=TCP -P 3306 Jive230 -p

The file you would be after in that case would be:

/etc/sysconfig/mysqld

and in that file, you’'ll want to comment out the line:

MYSQLD_OPTIONS="–skip-networking"

I’‘ll bet that’'s what it is. I took a look at that file on Saturday, and I know that line is in fact there.

I’‘ve got the machine off my bench right now, but I’'ll take a look at it later today. It sounds like that is in fact the problem.

Thanks! I’'ll let you all know.

If I run the application from my account (admsjc), I

get the error.

If I do an ‘‘su’’ and then start the messenger, I can

get into the configuration utility.

make sure admsjc is the owner of JM dir and subdirs:

ls -l

if it’'s owned by root, then you should change it to:

chown -R admsjc:group_this_user_belongs_to /opt/jive_messenger/