powered by Jive Software

You are not currently logged into the YAHOO transport error in Openfire

I am able to login to Yahoo through the Spark Client and I can see my Yahoo Clients, they can IM me, but when I try to IM them I get the following error.

You are not currently logged into the YAHOO transport.

I just found out that even though the other user does not get my IMs, both sides of the conversation is logged by Openfire.

I am using the 2.5.3 client with the Openfire Enterprise 3.3.1 server with the 1.0.2 IM Gateway.

Looking at the logs it appears that there is an issue with Yahoo session listener :

2007.06.13 13:25:00

[org.jivesoftware.openfire.gateway.protocols.yahoo.YahooSessionListener.

inputExceptionThrown(YahooSessionListener.java:185)] Input error from

yahoo: Source: InputThread

ymsg.network.YMSG9BadFormatException: Bad parse of online friends in logon packet

I have tried to remove and re-add the registration Gateway Registrations with no luck.

Since this only seems to be with my account, could this be something with my user on the yahoo IM servers?

Please help me Daniel Henninger, you are my only hope.

Thank you,

Sven

Message was edited by: svenmead

I’‘m afraid I can’‘t help you much with 1.0.2. =) The Yahoo transport is unstable because the library I’‘m using there sucks. 1.1.0 has a new library that is much more supportable! If you don’'t mind, would you mind trying the beta version off of the beta plugins page? It already solves a lot of issues. =)

This worked great. Thank you!

Sven

Awesome, glad to hear it!! Thanks for letting me know!