powered by Jive Software

2.1.* and ldap

This is the first time i’'ve setup jive to use AD

yesterday i was using 2.1.3 and after a little trouble i got everything working. Well this morning i added a few more users into groups and i could no longer connect. My client just sits at please wait. So then i upgraded to 2.1.4 no change. The admin console shows my username as authenticated.

Yet i cannot login.

in warn.log i get this error message

005.06.03 10:12:24 Closing no longer valid connection

org.jivesoftware.messenger.net.SocketConnection@e8f8c5 socket: Socket[addr=/192.168.1.76,port=1142,localport=5222] session: org.jivesoftware.messenger.ClientSession@1248979 status: 3 address: bobt@im/TCIm id: cf26b0a3 presence:

java.net.SocketException: Software caused connection abort: socket write error

at java.net.SocketOutputStream.socketWrite0(Native Method)

at java.net.SocketOutputStream.socketWrite(Unknown Source)

at java.net.SocketOutputStream.write(Unknown Source)

at sun.nio.cs.StreamEncoder$CharsetSE.writeBytes(Unknown Source)

at sun.nio.cs.StreamEncoder$CharsetSE.implFlushBuffer(Unknown Source)

at sun.nio.cs.StreamEncoder$CharsetSE.implFlush(Unknown Source)

at sun.nio.cs.StreamEncoder.flush(Unknown Source)

at java.io.OutputStreamWriter.flush(Unknown Source)

at java.io.BufferedWriter.flush(Unknown Source)

at org.jivesoftware.messenger.net.SocketConnection.validate(SocketConnection.java: 94)

at org.jivesoftware.messenger.SessionManager.isActiveRoute(SessionManager.java:621 )

at org.jivesoftware.messenger.handler.IQAuthHandler.login(IQAuthHandler.java:191)

at org.jivesoftware.messenger.handler.IQAuthHandler.handleIQ(IQAuthHandler.java:14 1)

at org.jivesoftware.messenger.handler.IQHandler.process(IQHandler.java:48)

at org.jivesoftware.messenger.IQRouter.handle(IQRouter.java:202)

at org.jivesoftware.messenger.IQRouter.route(IQRouter.java:73)

at org.jivesoftware.messenger.PacketRouter.route(PacketRouter.java:65)

at org.jivesoftware.messenger.net.SocketReadThread.readStream(SocketReadThread.jav a:285)

at org.jivesoftware.messenger.net.SocketReadThread.run(SocketReadThread.java:105)

and in debug i just get the sucessfull lookups of my username.

i’'m stumped…

your client/clients?

Hey Andrew,

Could you describe in more detail what you are doing, steps to follow and what’'s not working? The error that you posted was generated because the server was checking if a connection was dead and decided to discard it since it was dead.

Regards,

– Gato

I tried pandion and trillian, Neither would connect.

I created 5 groups added about 3 people in each and tried to sign on… That’‘s it. It won’'t connect. but the admin pannel says “authorized” for my session.

So i dumped the database, and started over again it worked until either i signed on with more then one person. Or add more then 5 groups, it stops working…

Kind of dumb founded.

Andrew,

Could you check if there are more errors in the log files? Are you using LDAP? I will need more detailed information on how to reproduce the problem. Maybe posting the XML that the client is sending and receiving could help.

Regards,

– Gato

I wish i could attach a file… well i pmed you the location of the logs… maybe you can see where the error is.

I’'m using LDAP

Things just got interesting… I deleted all groups and now i can sign on.

The first person still sees the group i deleted. and the second person sees no groups…

so then i create a new group called something else… neither user can see the new group and the first user still sees the original group i deleted.

I’'m lost now.

I’'ve noticed that certain clients save group information locally on the clients hard drive and they still show up after you delete them from the server. May or may not be your case.

OK so move blame from the client, when i turn off ldap and dump the database then it works perfectly. but no i don’'t have ldap

When i was running ldap and i deleted a group it took like 10 minutes and my CPU ussage was maxed at 100% during this whole time

Hey Andrew,

Could you try using the latest nightly build and Exodus as your client? Let me know if you are still observing the high CPU usage and the ghost groups in the client.

Thanks,

– Gato

ok so i wiped out the database… copied the files over from this mornings (06-09-2005) build, and then started up the jive server using ldap

ran exodus on both machines and tried to connect. the first one connected fine… the second would not connect. Then i logged off the first one and tried to connect again and it would not… Exodus gives the following in the contact window…

Authenticated

Getting contacts…

the xml debug log says

SENT:

SENT:

RECV:

that’'s it.

Andrew,

Can you get a thread dump when the exodus client hangs? I would like to see why the server is not answering the roster. Have you checked the other log files? Anything there?

Regards,

– Gato

how do you get the thread dump? i can send you all the logs from jive again if you want them.

The client never freezes it just waits for a roster.

It looks like it gets the conference stuff fine, but no contacts.

Looking up SRV: xmpp-client.tcp.im

Direct DNS failed… Using server: im

SENT: <stream:stream to=“im” xmlns=“jabber:client” xmlns:stream=“http://etherx.jabber.org/streams” xml:lang=“en” version=“1.0” >

RECV: <?xml version=''1.0'' encoding=''UTF-8''?><stream:stream xmlns:stream=“http://etherx.jabber.org/streams” xmlns=“jabber:client” from=“im” id=“a5bcc057” xml:lang=“en”>

SENT: bobt

RECV: bobt< /iq>

SENT: bobttcim*****

RECV:

SENT:

SENT:

SENT:

SENT: Available1

SENT:

AUTOUPDATE. Last = 4/2/2005 10:09:45 PM

AUTOUPDATE: Rounded = 4/2/2005 10:09:45 PM

RECV:

RECV:

SENT:

RECV:

RECV:

SENT:

RECV:

bump

Andrew,

I don’'t know which OS you are using. If you are using linux/unix then execute "kill -3 " and the dump will be printed on the nohup file. Send me the thread dump and the log files then.

Thanks,

– Gato

NO i’'m using the windows version.

I’'m still having a problem…

I’'m using the nightly build from the 21st

and btw it still says

Jive Messenger 2.2.0 Beta 1

thanks,

Andrew

Using 2.1.5 under Linux (working against a W2K server for LDAP), I’'m running into the same issue. Has any resolution been reached?

Update:[/b]

Also occurs with the 7/6 nightly build. 2 groups created, each with two users. Using Pandion. Pandion’'s log ends with this:

SENT:

Will

Message was edited by:

wdimmit