2.5.8 MSI install requires admin for first run

I’m testing to deploy Spark to my company with about 150-200 users located around the country, and I’m running into an issue:

We’re on a Win2k domain and regular users don’t have admin. On computers where the Spark MSI is installed either directly by the user or in a silent network install with admin rights, Spark refuses to start. Watching taskmgr processes shows the process launch and immediately die. No logs, no nothing.

I can log in as an admin and run the program with admin rights, log off and a regular user on that machine then has full access to run the application.

I’ve checked the JRE version on the PCs and it’s 1.6 (using the 44mb MSI installer, does that come with JRE as well?). I also edited the MSI to install a shortcut to the Startup group, but the problem occurs with an unedited MSI.

I’d like to get this deployed, but I don’t want to have to log on to every machine in the company to do it. The network install is ready, I’ve even got the JRE1.6 MSI ready for network installs just in case. This is the last piece, any ideas?

This is a known issue (i have a thread about this here myself), but no good solution so far. Spark has to extract some files in Program Files directory upon first startup. Obviously it should be done during setup. But i’m not hoping to see a solution from developers quickly, as Spark project is a bit slowing down (new developer, other priorities).

Thanks wroot!

When you encountered this problem, were you able to find a workaround?

I created a completely custome installer using EMCO MSI builder. I did this to add icons to statup items and copy some default settings to the default user profile. I also modified several graphics to make spark use our corporate logo. My msi build installs fine with no errors. All users can use it immediately regardless of user rights. I am in an AD 2003 environment, Using XP SP2 for clients, Server 2003 for the Server, SSO for authentication to AD LDAP.

Sorry. I dont have a workaround.

there could be a solution in 2.5.9 release - SPARK-906

hi mtstravel,

Your suggestion seem to be the ideal world for us to deploy the spark.

Are you use the EMCO mai builder with the spark…msi? could you explain a bit moer how to change the logo please.

When you said you using SSO, is it something you could add register key and move the ini file in to windows folder?

here the link i been reading how to create SSO http://www.igniterealtime.org/community/docs/DOC-1362

Thanks ZikusA

I use EMCO to watch the install of the exe installer. This then copies all files and settings to the EMCO folder. You can use a program lik 7zip to view the contents of the spark.jar file. All the images are in this file. Create new images of the same dimenssion and copy them to the jar file (replacing the original). Yes you can add the registry edits and the ini file to the msi project in EMCO at this point.

I would watch out when doing this, as I tried the EMCO route and while it produced a MSI that worked, it would no longer install remotely. EMCO support could not find anything wrong with the MSI but reproduced the problem.

That is very odd. I have created 20+ msi files that have never failed to deploy to the computers via AD policy. I have built every versionof Spark from 2.5.0 to 2.5.8 in EMCO using the manner described with no issues.

I’m in the process of deploying Spark with Group Policy. I’ve run in to the auto run registry entry issue and the first run issue. As a work around I’ve added the following to my startup bat to fix the first run issue. This works on windows XP, I haven’t tested it on 2k. It basically checks for the sparks folder in Program Files and if it exists gives domain users full control to the Spark directory.

If not exist “C:\Program Files\Spark” GOTO END
cacls “C:\Program Files\Spark” /E /T /C /G “Domain Users:F”


When I’m done deploying the software I’ll change the line to only allow users to change files…

If not exist “C:\Program Files\Spark” GOTO END
cacls “C:\Program Files\Spark” /E /T /C /G “Domain Users:C”


I just manually edited the registry entry on my PC then exported it, to correct the exe name on the MSI install and added it to my domain workstations startup bat.

If not exist “C:\Program Files\Spark” GOTO END

REGEDIT /S \\NETLOGON\spark\run.reg


The run.reg file looks like this

Windows Registry Editor Version 5.00

“Spark”=“C:\Program Files\Spark\spark.exe”

It’s not ideal but it works!