powered by Jive Software

2.8.3 No Logout Option?

So there appears to be a bug where there is no “logout” option on 2.8.3. This can create an issue if the user has chosen to auto-login and saved his/her password and we need to change something in the program settings because those are only available when you launch the client and BEFORE you login.

Not only that but the software still occasionally will lock up and not be able to be woken up when “closed” for a long period of time and end users generally are not smart enough to know how to end processes.

Do you have Client Control plugin installed on Openfire server? Then check its settings. Maybe you have logout option disabled there.

This may sound stupid but where are the plugin settings? It doesn’t seem that it is on the plugin page itself. I just looked at the “Client Features” section and "Logout & Exit (Spark Only) is set to Enabled. I pressed “Save” again thinking maybe that will kick in something and that seemed to work. I now have the option to log out.

It’s not stupid. There are no actual settings on the Plugins page itself, it is only used to install/update/uninstall plugins. Every plugin then creates its own menu in Admin Console. I have submitted an update to Client Control readme to point where to find its menu https://github.com/igniterealtime/openfire-clientControl-plugin/issues/15 (this change will be applied when new version of this plugin is released, which won’t be soon unfortunately).

So, your issue is fixed? You can mark your last reply or mine as a solution (press … and then a checkbox).

Technically your post wasn’t the answer because that setting was already set but not applying for some unknown reason. All I did was hit the “save” button again and it seemed to actually apply the setting along with all kinds of other settings on the client.

Marked as Solution anyway.

Thank you for your help.

You could have marked your own post. But that’s just semantics. Importantly, now your issue is gone :wink: