3.10 RC LDAP Issue

After upgrading from 3.9.1 to 3.10 the Spark client receives “Invalid username or Password” I am using Windows 2008 R2 Active Directory. This worked fine under 3.9.1. What is even more puzzling is that SparkWeb CAN login using LDAP credentials it is the Fat Client giving me trouble.

I’m running same, 2008 R2 AD and 3.10. Experiencing same issue, but only for those that have Spark set to start with windows and auto-login. I had them leave the start with windows on, but turned off the auto-login and had them manually click the connect button. Seems to work for all so far, 137 users, no complaints after emailing that set of instructions.

This problem has been added to our issue tracker as https://igniterealtime.org/issues/browse/OF-904

I also installed openfire 3.10rc with ldap authentication and I had no errors.

Which version of spark used?

I use spark spark_2_7_0_669

Dan, Are you using user/group filters?

I found the Answer… I went to the Server Tab> Server Settings> Security Settings and set all security as custom and set TLS method “Not Available”.

Issue resolved

The problem still exists in the official release of 3.10.0

So we have to turn of encryption between the client and the server?

That shouldn’t be an acceptable answer

My guess is that you have to enable SSLv2/SSLv3 on Openfire

Next i suggest this (from a different post):

RSS not working is a known problem (after switching to https on the site) https://igniterealtime.org/issues/browse/OF-798

And now i think, could it be related

you can try first disabling RSS, by adding a system property rss.enabled with a value false

then restart Openfire and see if it helps, though i doubt

I think the most probable thing causing login failure with SSL/TLS is the built-in Java update in Openfire 3.10.0 (bumped to 1.7.0_79). You can try a few things. Updating Spark to the latest 2.7.0 build http://bamboo.igniterealtime.org/artifact/SPARK-INSTALL4J/shared/build-669/Insta ll4j/spark_2_7_0_669.exe

Or you can try copying old jre folder form Openfire 3.9.3 (or Spark 2.6.3) into Openfire 3.10.0 installation folder (first delete current jre folder in there).

Thanks wroot, I upgraded Spark to version 2.7.0 and set all security back to defaults and everything works.

I know this isn’t the Spark section, but I did a quick search and didn’t find the answer… when will 2.7.0 be official? I don’t want to install a client on 75 machines and then turn around and have to install it again a month later.

I’m trying to push the release and asked in the planning forun to help with that, especially that now many users will be affected after updating to 3.10.0. But I’m not a developer and there is currently no other developer working on spark. Building a release is probably not a problem and i will find someone to do this. But first source must be tagged for new release or something. So, waiting for a response.

Btw, it probably will be the same version i gave a link for, just marked as final. No changes are planned. So you won’t need to update it later. Also, i suggest using some kind of script (via gpo) to update your users easily.

Jamie, you are lucky, Spark 2.7.0 has been just released build is the current final one (can be found on the Downloads page).

1 Like

That’s awesome!!! Thanks! I’ll give that a try with 3.10.0 of Openfire!

**Edit - I tried it with 3.10.0 upgrading 3.8.1 and it works perfectly!