powered by Jive Software

3.2.0 upgrade - Invalid Username or Password

Hello,

The upgrade from 3.1.1 went smoothly to 3.2.0 - I followed the directions.

However, now none of our clients can connect - we all get “invalid username or password” errors each time.

Nothing has changed in LDAP, configuration, etc.

Any pointers would be nice, as we haven’'t had any issues since before 3.x.

I might add that I have also tried removing all the plugins and installing the latest from the web site - that now allows me to log back in, but the web page is unavailable, and Spark 2.0.8 shows a blank screen most of the time. Very odd.

Same here. Looks like the native authentication is somehow broken. I am using nativeAuth on Red Hat Linux and every password attempt can be seen in /var/log/secure as invalid, even if I change my password to a simple one.

Worked fine in 3.1.1, but I cannot find the old RPM package anywhere. The Ignite pages only have the broken 3.2.0

I fixed it, but it wasn’'t pretty…

I uninstalled the 3.2.0 version, DB and all.

Installed fresh copy, configured, only has ONE plugin. Updating the plugins shows a bunch, but they won’'t download and install.

Only thing missing now that worked on the old one is VCARDS, so we apparently now can’'t use pictures.

Can’'t figure out what changed.

I’'m just answering myself as I go here - hopefully someone else might benefit…

I added in the plugins (4 of them) one at a time by copying them into the directory, waiting a few min. They all work just fine now.

VCARDS - it’'s read only to my LDAP (naturally), so I went into the wildfire config file

(C:\program files\wildfire\conf\wildfire.xml)

and commented out the VCARD provider so it looks like this:

and now we can set our images again. Naturally we now no longer see the VCARD information, but we weren’'t storing that anyway. People are happier that they get to use the pictures.

Message was edited by: jreynolds

And my problem was caused by running Wildfire as non-root user, which caused shaj.so to be unable to authenticate user.

Are they going to post a patch for all the problems 3.2 has caused? The other thing I have noticed, is no longer can you manage the client version within the admin console…looks like in their wisdom, they took this feature out…If I could back out 3.2 and go back to 3.1.x I would…

Stephen…

I have been having the same problem. I hope they fix it, I reinstalled 3.1.1 and everything works again. I guess I’‘m going to start living by the rule if isn’'t broke don’t fix it.

Hey Stephen,

I would say that both problems that were reported where not Wildfire’'s issues but setup problems. As mentioned the native authentication was not working in one setup because “Wildfire was running as non-root user, which caused shaj.so to be unable to authenticate user.”.

The other problem with vCards was also a misconfiguration. When using LDAP, vCards are read-only so if users want to still configure their own vCards from their client then the only solution is to store vCards in the database instead of LDAP. It seems that in the previous setup vCards where being stored in the database but when the setup was updated the configuration was modified to read them from LDAP.

Hey beastcmg,

What problem are you having? Is your problem different to the ones reported in this thread?

Regards,

– Gato

we are running a SQL database and connecting to ldap (running win-server ''03) Did the update and after starting the service we tried to log on with spark and got Invalid Username or Password. I would think if every thing works in 3.1.1 it would work in 3.2. I followed the update but still cant get it to work so we are staying with 3.1.1 for now.

Hey Chad,

So your case is different from the ones reported in this thread. You are not using native authentication and the problem is not related to vCards in LDAP.

I would say that between Wildfire 3.1.1 and Wildfire 3.2.0 there were no changes in LDAP code that could be producing this problem. My guess is that while upgrading to Wildfire 3.2.0 your setup was different (your LDAP integration settings) so it stopped working. Have you tried using the old conf/wildfire.xml with Wildfire 3.2.0? BTW, do you see any error or warning in the log files?

Regards,

– Gato

Hi there, did you just re-install 3.1.1 straight over the top of 3.2.0 and all worked fine again? I don’'t want to re-install 3.1.1 over 3.2.0 if it is going to kill it competely…

Thanks, Stephen…

We have the same problem, windows server, just reinstalled 3.1.1 over the top of 3.2 seems that everything is fine now.

I’‘m having very similar problems to those mentioned here. I’'m getting “invalid username or password”.

Overwritten my 3.0.1 installation with 3.2.0 and then replaced the new wildfire.conf file with my old one (after removing all references to vcard).

Nothing has changed regarding our LDAP config (I’'m connecting to Active Directory) - and the administrator access via web browser uses LDAP and works.

My config is below (anonymised):


++

<![CDATA[

(&

(objectCategory=Person)

(memberOf=cn=jabberaccess,ou=groups,ou=myou,dc=mydomain,dc=local)

(!(userAccountControl:1.2.840.113556.1.4.803:=2))

(sAMAccountName=)+
+)+
+]]>+
++
++
<![CDATA[
(&
(objectClass=group)
(memberOf=cn=JabberAccess,ou=Groups,ou=myou,dc=mydomain,dc=local)
+(member=)

)

]]>

org.jivesoftware.wildfire.ldap.LdapUserProvider

org.jivesoftware.wildfire.ldap.LdapAuthProvider

org.jivesoftware.wildfire.ldap.LdapGroupProvider

org.jivesoftware.database.EmbeddedConnectionProvider

true

false


I also get the following in the logs:


2007.02.16 10:39:10 [org.jivesoftware.wildfire.container.PluginManager.loadPlugin(PluginManager.jav a:466)

] Error loading plugin

java.lang.ClassNotFoundException: org.jivesoftware.wildfire.plugin.SearchPlugin

at java.net.URLClassLoader$1.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at org.jivesoftware.wildfire.container.PluginClassLoader.loadClass(PluginClassLoad er.java:156)

at org.jivesoftware.wildfire.container.PluginManager.loadPlugin(PluginManager.java :345)

at org.jivesoftware.wildfire.container.PluginManager.access$200(PluginManager.java :46)

at org.jivesoftware.wildfire.container.PluginManager$PluginMonitor.run(PluginManag er.java:920)

at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)

at java.util.concurrent.FutureTask.runAndReset(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknow n Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)


I have I-Ball Chat Aduitor and Spark Manager plugins installed.

If I roll back to my old version (glad I backed up first) it all works fine again.

I’'m using Spark as a client (various versions). Wildfire is running on Windows 2003 Server

Alastair

Message was edited by: alastairweller

I’‘m having the same problem as you and I don’‘t see the developers of Wildfire doing anything about it. I was running 3.11 and upgraded to 3.2. Users could no longer log in. I then reinstalled 3.11 and everything works, however, I’'m running v3.11 and I need to run v3.2 so I can upgrade to v3.3 Openfire.

How can I upgrade to 3.2? I was going to uninstall the two plugins I have installed, however, where can I get the v3.2 plugins?!

I found the problem was solved when I installed 3.2.1 instead.

Alastair