powered by Jive Software

3.4.3 rpm delete bug

Hi, While attempting to remove the openfire-3.4.3 rpm on RHEL 5, I ran across a bug.

If openfire is not running, preuninstall will fail causing rpm to fail:

if ; then

  1. This is an uninstall, instead of an upgrade.

/sbin/chkconfig --del openfire

&& /etc/init.d/openfire stop

fi

/code

I am not sure what to suggest for a fix, as I suspect you aren’t using the ‘service’ command since it doesn’t exist on all linux platforms.

daryl

Hrm. What error shows up??

hi! Here is the error:

service openfire stop

Shutting down openfire:

rpm -e openfire

Shutting down openfire:

error: %preun(openfire-3.4.3-1.i386) scriptlet failed, exit status 1

rpm -q openfire

openfire-3.4.3-1

/code

Huh. I didn’t know scriptlets were so “fragile”. =) I guess it makes sense, give the script the ability to abort the uninstall or install. JM-1233 Thanks!

thanks jadestorm. Your fix worked for me.

fyi, I do get this warning now with install:

warning: user ci does not exist - using root

warning: group jivedev does not exist - using root

Huh. good question. JM-1248 Thanks!