powered by Jive Software

3.5.0 RC1 BETA - no setup wizard

Using either rpm or tar download I get the some problem - after installation and browsing to :9090, I get the login prompt, not the setup wizard.

I checked out conf/openfire.xml and there was no <setup /> values. I manually added <setup>false</setup> and restarted openfire, but no change, still the logon and no setup.

How do I fix this?

Hrm. I can’t reproduce this. Is anyone else seeing it?

Just to check I’m not insane, I renamed openfire.xml and restarted the server and duly got a failed startup, so it’s defo reading the file. Here’s the openfire.xml. The other change I had to do was after the bin/extra/readhat-postinstall.sh I had to edit /etc/init.d/openfired so that it called “openfire” and not “openfire.sh”. That’s all I changed. Nothing in the logs giving any clues. Stumped.

<?xml version=“1.0” encoding=“UTF-8”?>

<!–

This file stores bootstrap properties needed by Openfire.

Property names must be in the format: “prop.name.is.blah=value”

That will be stored as:

<prop>

<name>

<is>

<blah>value</blah>

</is>

</name>

</prop>

Most properties are stored in the Openfire database. A

property viewer and editor is included in the admin console.

–>

<!-- root element, all properties must be under this element -->

<jive>

<adminConsole>

<!-- Disable either port by setting the value to -1 -->

<port>9090</port>

<securePort>9091</securePort>

</adminConsole>

<admin>

<!-- Use this section to define users that will have admin privileges. Below,

you will find two ways to specify which users are admins. Admins will

have access to the admin console (only local users) and may have also access

to other functionalities like ad-hoc commands. -->

<!-- By default, only the user with the username “admin” can login

to the admin console. Alternatively, you can specify a comma-delimitted

list usernames that should be authorized to login to the admin console

by setting the <authorizedUsernames> field below. -->

<!-- <authorizedUsernames></authorizedUsernames> -->

<!-- Comma-delimitted list of bare JIDs. The JIDs may belong to local

or remote users. -->

<!-- <authorizedJIDs></authorizedJIDs> -->

</admin>

<locale>en</locale>

<!-- Network settings. By default, Openfire will bind to all network interfaces.

Alternatively, you can specify a specific network interfaces that the server

will listen on. For example, 127.0.0.1. This setting is generally only useful

on multi-homed servers. -->

<!–

<network>

<interface></interface>

</network>

–>

<setup>false</setup>

</jive>

Hrm. Well first off, you shouldn’t run the redhat-postinstall if you installed via RPM anymore. It’s obsolete. If you used the tar file, you would probably still need to. Are you seeing anything in the error logs? Off the top of my head I don’t see any reason why this would be occurring. =/ The only other thing I can think of is if there’s another copy of Openfire running that wasn’t killed off from a previous install.

I only ran the redhat-postinstall.sh after the tar thang… it kind of bugs me that neither install works straight off the bat, like having to change the script name in the init script <bah!>

Once more with feeling… I’ll stop Openfire, remove the tar install, and use the rpm install… that should work first time, right?

OK, here’ some more badness…

Ran the rpm install

$ sudo rpm -ivh jive/openfire-3.5.0.rc1-1.i386.rpm

Preparing… ###########################################

1:openfire ###########################################

$ sudo /etc/init.d/open

openfire openfired openibd

$ sudo /etc/init.d/openfire start

Starting openfire:

$ ps -ef | grep open

daemon 23384 1 99 17:26 pts/1 00:00:05 /opt/jdk1.6.0_02/bin/java -server -DopenfireHome=/opt/openfire -Dopenfire.lib.dir=/opt/openfire/lib -classpath /opt/openfire/lib/startup.jar -jar /opt/openfire/lib/startup.jar

502 23407 22904 0 17:26 pts/1 00:00:00 grep open

In the browser I go to :9090 and get the logon again, not the setup. Here’s the real output from a telnet - it’s pointing me to index.jsp (should it be something else?)

$ telnet 0 9090

Trying 0.0.0.0…

Connected to 0 (0.0.0.0).

Escape character is ‘^]’.

GET / HTTP/1.0

HTTP/1.1 200 OK

Expires: Thu, 01 Jan 1970 00:00:00 GMT

Set-Cookie: JSESSIONID=1tor7me052aky;Path=/

Content-Type: text/html

Last-Modified: Tue, 11 Mar 2008 21:12:59 GMT

Accept-Ranges: bytes

Content-Length: 115

<html>

<head><title></title>

<meta http-equiv=“refresh” content=“0;URL=index.jsp”>

</head>

<body>

</body>

</html>

Connection closed by foreign host.

Fixed it - some crazy permissions in these directories causing wierdness in file reads… not sure I understand it, but its working now - I’ll blame user error, but I’ll try to recreate it. Thanks for help!

Wow, well congratulations on getting it going and sorry it wasn’t behaving! Lemme know if you find something else.

It wasn’t permissions, it was network stuff… local confusion at our end.

However, the tar file still needs to be corrected (init.d script tries to call openfire.sh when the script is called openfire).

I guess my problems started when I saw that the initial download wasn’t 100% pure of course I assumed the worse (it was Jive’s fault), when of course the usual theory applied (PAUSE - Problem At User Site Exception)

Thanks for the prompt help though, that was very much appreciated - just confirming that you didn’t have the issue lead to my resolving it.

THANKS!