powered by Jive Software

A connection to the database could not be made

I’'m running FC3 w/MySQL 4.1.11. Wildfire is on the same server as MySQL, so my GUI Setup settings are:

com.mysql.jdbc.Driver

jdbc:mysql://127.0.0.1:3306/messenger

using a valid user/pass

But when I try to “continue” I get this error:

A connection to the database could not be made. View the error message by opening the “/logs/error.log” log file, then go back to fix the problem.

and the log shows:

org.jivesoftware.database.DefaultConnectionProvider.getConnection(DefaultConnect ionProvider.java:68) Warning: DbConnectionDefaultPool.getConnection() was called before the internal pool has been initialized.

org.jivesoftware.database.DbConnectionManager.getConnection(DbConnectionManager. java:107) WARNING: ConnectionManager.getConnection() failed to obtain a connection.

I know the user/pass is correct and I can connect just fine via TCP/IP from other clients (Navicat, for example).

Any ideas?

By the way, I also tried localhost.localdomain … same error.

I have a localhost entry in the users table, so I don’‘t think that’'s the problem.

Ronnie,

There should be another error message before the one you pasted with a more specific error about why it’'s not able to connect to the database. Can you check that out and paste it in to this thread?

Thanks,

Matt

three of these…

2005.12.21 09:52:03 [org.jivesoftware.database.ConnectionPool.(ConnectionPool.java:108)] Failed to create new connections on startup. Attempt 1 of 3

java.sql.SQLException: null, message from server: “Host ‘‘localhost.localdomain’’ is not allowed to connect to this MySQL server”

Does that help?

My current settings are:

jdbc:mysql://localhost/messenger (messenger is the dbase)

FYI… I have a localhost host entry in my mysql users table… user/pass required.

I figured it out.

I have several mysql users in my “user” table:

locahost (w/user & pass)

192.%.%.% (w/user & pass)

serverhostname (w/user & no pass??)

I had been trying the localhost setting with a valid user/pass, but it didn’'t work.

Just for kicks, I tried the host name with the user and NO pass (to match the entry in my users table) and IT WORKED!

I’‘m not sure why, but if you’'re having the same problems, try another valid host/user/pass combination.

Thank you for posting your solution. It helped me in figuring out my problem. I was here scratching my head out yesturday with not making the connection and today BAMM it worked!! Thanks!!!