powered by Jive Software

A plugin problem?

I have done a plugin according to the example, added a JSP file in the plugin package, put in src\plugins\myplugin\src\web catalogue , produced a JAR file, putting in MESSENGER\plugins,i can see newly-increased column in the admin console,it can’'t display when cliked item.the error is ''HTTP 404 - have no found the file.

i attached up jar.

The plugin works just fine for me, actually. Are you using the final release of 2.1.0? I attached screen shots from my instance.


shot2.png (42641 Bytes)
shot1.png (65535 Bytes)

i try it is right on messenger for windows,but i put myplugin.jar into messenger for linux,it is a error that file isn’'t find.i analyse problem is path in linux,why do it set plugin path in linux?

continue above,i do ‘‘ant plugins’’ on linux,it can built to jar,but it have a error that put myplugin in messenger/plugins and jsp isn’'t display when clicked admin console label ‘‘example’’.

it’'s error.log:

2005.01.21 10:36:21 org.jivesoftware.messenger.container.PluginServlet.registerServlets(PluginServle t.java:146)

org.dom4j.DocumentException: java.sun.com Nested exception: java.sun.com

at org.dom4j.io.SAXReader.read(SAXReader.java:353)

at org.dom4j.io.SAXReader.read(SAXReader.java:222)

at org.jivesoftware.messenger.container.PluginServlet.registerServlets(PluginServl et.java:116)

at org.jivesoftware.messenger.container.PluginManager.loadPlugin(PluginManager.jav a:125)

at org.jivesoftware.messenger.container.PluginManager.access$300(PluginManager.jav a:39)

at org.jivesoftware.messenger.container.PluginManager$PluginMonitor.run(PluginMana ger.java:256)

at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)

Hi Tom and Matt,

I’‘m seeing the same exceptions on 2.1.0 and 2.1.1 (src builds) with both Tom’'s plugin and a real simple one that I created from scratch.



Message was edited by:

Ryan Graham

Hey guys,

I have a new theory on this issue. Some firewalls might block Jive Messenger from making connections to outside servers. By default, XML parsers will try to resolve external DTDs – I think the DTD resolution in the web.xml file is breaking due to your firewall configurations. The “fix” would be to disable validation on the SAX parser. This is a one-line change, but it would be great to get your help testing since we can’'t duplicate the issue locally.



The issue was filed as JM-164 and is now fixed!