powered by Jive Software

Aaaauuuugggghhhh!

First let me say I LOVE Widefire / Openfire but I am very upset about how the latest upgrade process.

Today I was prompted to upgrade just like past upgrades. The link pointed me to the new download. I ran the new download only to find out that unlike upgrades in the past my old version was COMPLETLY wiped out!

I REALLY wish during the upgrade a notice would have stated that unlike old upgrades this one would not convert your old database automatically and it would be deleted.

I am soooo screwed.

Any way to get my old data back?

Welcome to the club!

I do love Wildifre too but I have a similar problem:

http://www.igniterealtime.org/forum/thread.jspa?threadID=25866&tstart=0

but mine is about plugins that no longer run on my 3.1.1 version and require the 3.3

Such critical updates should warn the user first, then should not be processed if the user doesn’'t have the appropriate version.

I am really sorry sorry to say it, but the impact of this upgrade was mis-evaluated.

The employee Calls and Emails are starting to come in now asking why they cannot log into Spark. Uuuggghhh… Now I have to re-created each and every single account over again.

I am SHOCKED that during the upgrade process NOWHERE was it stated that your old database would be deleted .

Hey guys,

Sorry about that. I still need to post the news about Openfire 3.3.0 including the upgrade guide. But before doing that I need to check that the startup script included in the RPM is working fine.

Regards,

– Gato

This information should have been posted BEFORE wildfire notified me (and everyone else) to upgrade!

So I take it my old database is gone?

Hey RBasil,

I completely agree with you. Sorry about that.

– Gato

RBasil,

I now see that you updated your post and I do not agree with your last comment.

Take care,

– Gato

So much for my weekend off. I now get to input 3,000 usernames all over again. uuuggghhh…

What part of my last comment do you not agree with?

#1. That you should have the upgrade info posted BEFORE the upgrade notification.

or

#2. My database is gone.

RBasil,

I now see that you last comment is gone.

Were you using the embedded or an external database? In any case the information is not lost. If you were using the embedded then you need to rename the files as explained in the upgrade guide so that Openfire can locate it and use it.

Regards,

– Gato

Gato,

Embedded database.

Looks like that worked. YEA! Thanks! Having problems with the service for some reason. It installed just fine but I cannot connect to it (but that problem is for a different thread) at least the standard runfile works for now and I didn’'t have to retype 3,000 names.

Hey RBasil,

Good to hear that it is now working for you. The service in the init.d has to be updated too. You may want to remove the old one and create the new one that will use the bin/extra/openfired script instead of the old one bin/extra/wildfired.

Regards,

– Gato

I’'m on a windows box. So what should I update for the service?

I stopped the old one and installed the new one, but the new one will still not allow any connections.

I really like Openfire also, but my first response to all the upgrading is…

Do you backup your databases on a regular bases? If you did, you wouldn’'t be pulling your hair out thinking you had to re-create all your users.

I understand each admin has their own methods, but as a suggestion, the first thing I do before installing the newest version is to stop the service and back-up the entire install folder (I use built in db). That way if something goes wrong, I can revert to that back up and re-install the previous version.

Another question I have is since when does the automatic update force you to install the newest version? I just get a message on the main admin page that says there is a new version available.

I am glad I found this thread, I was searching all day for any documentation for updating from 3.2.4 to 3.3.

Thanks for the update!

Waiting on a fix for the service update on windows.

Hey RBasil,

Have you run these steps from the upgrade guide?

3) If running as a service then remove old service: wildfire-service /uninstall

10) Optionally install as a service again: openfire-service /install

Regards,

– Gato

Gato,

Yes I did. The old service was stopped and removed, the new service said it started fine (even in the windows services menu), but I could not connect with any clients or through the admin interface. As soon as I shut it down and then start the normal run file I can connect just fine.

Weird.