powered by Jive Software

Access denied for user 'odbc'@'localhost' failed

This is a re-install of openfire. Had everything working untill openfire wouldn’t connect to the database. Just got it running and testing for a couple of days so I just decided to delete it all databases and all and start over.

running on windows server 2003. went to create database using the command “mysqladmin create openfire” no quotes of course. and I get back the response "access denied for user ‘odbc’@‘localhost’ failed (using password: NO) ( I did not have this issue the first time I installed openfire). I have researched the user “odbc” and it seems it is the windows default user for mysql if none is entered. so I thought I did not create a password for this account. ok so i tried the command :

" mysqladmin -u root -pmypassword create openfire" ok that worked. still strange I thought. then i tried “type openfire_mysql.sql | mysql openfire;”

I get the same access denied error. soooooo i tried the command with my password and username and i get this error: Can’t create table ‘openfire.ofuser’ errno 121 the process tried to write to a nonexixtent pipe. getting frustrated at this point I tried the process over using the database “'openfire1” it worked! so I thought.

I start the admin module and I get this error when connecting to the data base:

2010.08.11 13:49:38 [org.jivesoftware.util.log.util.CommonsLogFactory$1.error(CommonsLogFactory.jav a:92)
] Prototype
java.sql.SQLException: null, message from server: "Host ‘E363260-126475’ is not allowed to connect to this MySQL server"
at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:946)
at com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:1070)
at com.mysql.jdbc.Connection.createNewIO(Connection.java:2775)
at com.mysql.jdbc.Connection.(Connection.java:1555)
at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:285)
at java.sql.DriverManager.getConnection(Unknown Source)
at java.sql.DriverManager.getConnection(Unknown Source)
at org.logicalcobwebs.proxool.DefaultConnectionBuilder.buildConnection(DefaultConn ectionBuilder.java:39)
at org.logicalcobwebs.proxool.Prototyper.buildConnection(Prototyper.java:159)
at org.logicalcobwebs.proxool.Prototyper.sweep(Prototyper.java:102)
at org.logicalcobwebs.proxool.PrototyperThread.run(PrototyperThread.java:44)

i used root as the user and itthe password. any ideas…

Hi,

this seems to be a problem of MySQL, so you may get better help in a MySQL forum. I sounds like a permission problem, so http://forums.mysql.com/read.php?86,23619,41248#msg-41248 may help.

LG

I went all through the permission info before i gave up. The good news i found the problem. when entering the local host name in the admin module I used the computer name as the host instead of “localhost” as to the odbc thing I don’t know what happened there.