powered by Jive Software

Active Directory and User Mapping problem

I am trying to get Openfire 3.6.4 on Linux to use AD. I have gone through the setup wizard and gotten as far as User Mapping. I pared down the atributes to only the three that I want to use. Then I got the error below. I have read other posts that have had the same problem. I am thinking that it has something to do with my base DN.

Test: User Mapping

A random profile is selected for you to review. Bold fields with no value mean that an error may have been found. To view another profile click ‘Next random profile’. When you are finished close this window.

Status: Error

No users were found using the specified configuration. Try changing the base DN, user filter or username field.

Here is the information that I am using. I tried removing the cn=Users from the Base DN, but then the connection doesn’t work. From othe posts, I am assuming that it has something tod do with the ADministrator in the OU=ASU not being able to find users in CN=Users. That is why I tried removing it, but that did not work. Any suggestions, other than maybe creating a special Openfire group or something like that?

Base DN: cn=Users,DC=my,DC=domain,DC=name,DC=local

Administrator DN: CN=Administrator,OU=ASU,DC=myl,DC=domain,DC=name,DC=local

For me the trick was the following:

Base DN: dc=“domain”,dc=“local”

Administrator DN : user@domain.local

Try that first then if that works for all your users there is another post on here about setting up the filter property based on groups.

Good luck!

Thanks for your reply. I tried this:

Base DN: DC=my,DC=domain,DC=com,DC=local

Administrator DN: CN=Administrator@domain.com.local

also tried

Administrator DN: CN=Administrator@domain.local

It says that there is a problem authenticating with LDAP. At least with my previous settings, I could authenticate. So, I guess I will look elsewhere on the forum. Thanks again.

For the Admin DN don’t use the DN syntax, just admin@domain.local

Well, I can authenticate to ldap successfully doing that, but I was able to do that before. The User Mapping still throws the same error.

frankly it is difficult to diagnose a mapping issue with fake info. Are your users located in the default AD container called Users or are they in a user created OU? Are you using any AD login security for authentication? is your AD structure firm or can it be restructured?