Active Directory Group Not Showing in OpenFire

Hello everyone,

I have a OpenFire server I just installed on my domain and I can’t get a group to show when users log in.

I previously had a OpenFire / Spark setup in my Non-Profit that had a User Group called “AllStaff” show up on everyones client that had a full list of all employees that were online at the moment.

I recently had to rebuild this due to a server upgrade. I tried reading some of the previous posts with this issue but I got lost in all the abbreviations. I tried a few fixes suggested but nothing worked so I returned all settings to their default values.

Looking at the properties of this group in Active Directory I have the following details

Canonical Name : GSCWM.local/Users/AllStaff

Object Class : Group

in the openfire admin panel I have a ldap.DN of “OU=Users,OU=Girl Scouts,DC=GSCWM,DC=local”

and a ldap.groupSearchFilter of (objectClass=group)

I can provide additional info if needed.

and I think I just made a big error. I removed the OU=GirlScouts from the ldap.DN as a test and now my domain account won’t let me into the admin console. Is there a xml file or something I can edit to correct that line?