powered by Jive Software

Adding Contacts

Hi

I installed Spark on Win2K. The installation was smooth. I am running Jive Messenger 2.2.2. Created a few users on the server. I am able to login with these users. But When I add users to contact list of each other. It shows “Pending” and there is no accpet message received at the other end. So one user sees the other as offline in their roster, though they are online.

Did I go wrong somewhere? Please help.

Thanks in advance.

Raj Das

Hi Raj,

When adding contacts did you enter their full JID in the Jabber ID field, i.e. newcontact@mycompany.com?

Thanks,

Ryan

Hi,

I have the same problem, noy only wuth Spark client, do not work with some IM Clients like Exodus.

I added the user in this format name@server

Thanks.

I have the same problem, noy only wuth Spark client,

do not work with some IM Clients like Exodus.

Double check to make sure you assigned the same domain name to Messenger that you’'re using to connect to with your clients. url=http://www.jivesoftware.org/community/entry.jspa?externalID=452&categoryID=2 2This document[/url] has some additional details.

Thanks,

Ryan

My contacts at Exodus and Pandion are registered as name@jabber.org/Exodus and name@jabber.org/Pandion, respectively.

hey mairlyn:

you don’'t need the resource on the end of the id, just name@jabber.org will suffice

you don’'t need the resource on the end of the id,

just name@jabber.org will suffice

Exodus actually tells you that it’‘s not typical to have it when adding contacts. I wonder if the jabberd has issues when you append the resource when adding a contact? Messenger doesn’'t seem to have this issue.

-Ryan

I have the same problem. I add the contact as michele@sub.domain.com. They all say pending. I look on the other machine to see if it prompts me to accept the request and it does not. What am I doing wrong? I have tried what has been suggested within this thread, but nothing is working. I have also tried michele @ sub. Any other suggestions?

Thank you.

Hi miwlliamson,

I’‘m looking into the packets being sent to see if there is an issue. I’'ll let you know as soon as I find out.

So the subscribe packet is being sent and I’'m unable to reproduce this case. However, there is a small issue when adding contacts to an empty list which will be fixed for the 1.0.1 release in the next couple weeks. Bug reference SPARK-11

I have sniffed the packets also and I also see that the request gets to the server and the server sends an ack back. It might be on the server side in my case. I am viewing the logs and see some errors popping up when I try to add a contact. Is there someone that could help decrypt the logs for me? They don’'t make too much sense to me. Some of it has to do with not being able to resolve the domain. nslookup at the server responds correctly.

Thanks.

The bug that you reference above, does that have anything to do with the error I get on Spark :

Thank you.

It does not. I’'m wondering why you are getting an error presence from test@ga.aocnetwork.us.

I have spark on three different workstations with each a different login. All clients say the same thing. I have noticed an error that Jive Messenger is not getting connected to the local DB. I am using the DB that came with Messenger. Is there a TTL on it?

BTW, are you using Jive Messenger 2.3.0 or another version?

Regards,

Matt

I am using 2.3.0. The logs are showing a connection timeout to the HSQL DB.

Can you post the connection timeout errors? I don’‘t think we’'ve ever seen something like that before.

Thanks,

Matt

I reinstalled Messenger on my Windows platform. When going through the wizard, it asks for hostname or IP. The hostname was already prefilled, so I left it the last two times I installed the software. This time I put in the FQDN of aocdev007.sub.domain.org. Now all is well. I could do a nslookup on the server with aocdev007 or the FQDN and still get the ip back so that is why this didn’'t occur to me any sooner. I could trace the packets back and forth, but Messenger just did not like the hostname only, although this is what the wizard asked for.

Anyways, thank you for your help.