powered by Jive Software

Admin accounts can not login

Hello,

We are faced witha n issue on solaris, using an external MySQL DB that the admin accounts just can no longer login after some time (maybe a few days). When we installed the server we created additional accounts (admin2, admin3, etc) and they worked fine after setup. Aftera few days the logins just stop working completely, no idea why.

The only way to fix it is to change false in openfire.xml and re-install to re-create the username.

Has anyone see this or know the root cause ? Its very frustrating to not be abe to login to the admin.

Thanks

You arent by any chance changing the openfire server host name in the settings are you? The login ID associated with ‘admin’ uses the JID.

ie. host name is ‘spark’

admin@spark would have to be a valid user, even though you only login as admin.

does this not happen by default? yes, we change the hostname to “chat.domain.com” during the install. Are you saying the login should go from admin to admin@chat.domain.com and it should work normally ? I believe we tried this with no success

Nope.

But, you will need to modify the database entries to compensate, OR, during the install, change the host name, and THEN edit the system properties to use the proper JID.

admin.authorizedJIDs will need to be updated with the proper JID’s.

Server manager->System Properties

So if after the initial setup, you had admin@chat.com in there, then changed teh host name to chat.domain.com you’ll need to change the JID to admin@chat.domain.com instead of admin@chat.com.