powered by Jive Software

Admin Console Won't Respond

We are currently on Openfire build 3.8.2 and daily we are experiencing an issue where we are unable to connect to the admin console on port 9090. We can see the server is still listening on this port but it appears the application (Openfire) isn’t responding. The only way to resolve this is the restart the openfire service. Is anyone else experiencing this issue?

Are the users still able to login/chat at this point? It sounds like out of memory problem, but then Openfire shiuld be stopping for users too. Or maybe some other tasks run on the server or in the network at this point of time (like backups, antivirus scans, etc.).

Yes, users are still able to login and chat using Spark. It only is affecting the admin console currently. My Openfire config is below:

-Xms1024m -Xmx2048m -Xss128k -Xoss128k -XX:ThreadStackSize=128

We are running Openfire on 64bit Linux with 4 GB of RAM reserving 2GB for Java.

I can look through the logs to see if Java is running out of memory. Typically which log (error, warn or info) whould show Java memory issues?

This is strange. Something is affecting Openfire’s web server or that port. I don’t remember what log, probably in error, but you can also check warn.

Currently there are no out of memory or memory errors in the logs. We made the Openfire config changes on Friday morning.

From: -Xmx2048m

To: -Xms1024m -Xmx2048m -Xss128k -Xoss128k -XX:ThreadStackSize=128

I haven’t experienced the admin console issue yet but usually it happens on high user load which won’t happen until Monday morning. I’ll report back early this week on if I can’t get into the admin again since applying the new Openfire config changes.

Yes, I meet the same issue with you - Spark can logon the port 5222, but the admin console on the port 9090 is not available.

moreover, at the initial installation the admin console is available. It can never open after restart server.

Regards,

It is very strange that the port 9090 is alive for openfire, but no response.

root@RD-DLTF:/home/jcrane/openfire/bin$
netstat -anp | grep 9090

tcp
0
0 :::9090
:::*
LISTEN
13240/java
tcp
0
0 ::ffff:192.168.10.204:9090 ::ffff:192.168.20.216:42534 ESTABLISHED 13240/java

This same thing happens for me on WIndows Server 2008 R2 about every 11-14 days. Server has 8GB of ram and the only thing that is running is Openfire and MS-SQL and currently there is 2GB of ram free but the admin interface is dead but the server is still accepting chat logins. I am running 32bit Java as I can never get Openfire to run using 64 bit java.

I have

-Xms64m

-Xmx768m

in my vmoptions but I hope someone would give me better settings.

We made two changes and since then, we haven’t had this issue occur again.

The first change we made was to disable avatar support. We are using LDAP authentication, the Kraken IM Gateway plugin and the Client Control plugin so we had to do the following.

In System Properties we set “ldap.override.avatar” to “false” and “plugin.gateway.xmpp.avatars” to “false”.

In Gateways > Transports > XMPP (which is the gateway we are using) > Options we unselected “Enable buddy icons”

In Client Management > Client Features we set “Avatar/VCard” to “disabled”

In the database itself we truncated the following tables “ofVCard”, “ofGatewayAvatars” and “ofGatewayVCards”

The second change we made was to the vmoptions file. Our file reads as-is.

-Xms1024m -Xmx2048m -Xss128k -Xoss128k -XX:ThreadStackSize=128

Since these changes, we’ve been up for 15 days without issues.

I hope this helps others.

For some reason if I put

-Xmx above 1024m I cannot launch Spark on Server 2008 R2

I ended up putting this.

-Xms128m

-Xmx1024m

-Xss128k

-Xoss128k

-XX:ThreadStackSize=128