Admin Login to console not working, server not allowing connections

So everytime I setup Openfire 3.7.0, it works great for a few hours. However, I just tried to login to the admin console and it tells me that my username or password is incorrect with my login, AND the admin login.

I checked the SQL db, and there are no tables in the database for openfire anymore.

Is this a bug where it deletes the tables? Or is there some thing else going on…

Some information:

Openfire 3.7.0

Windows Server 2008 R2

MySQL 5.5

Its not running in a VM, its running on the server itself. I have tried with both internal, and external DB’s, and both have this issue. I can create a new account using the registration plugin, so if I go to the address it loads the registration screen and allows me to create a new user, however I cannot log in to the server using that new user through Spark.

Any ideas?

Is openfire logging anything interesting to its log files on the server?


Not that I saw. I just reinstalled it using the embedded db, and have yet to have any issues yet.

I did notice another issue while I was installing it though;

I tried to use my MySQL server again, but it said that it couldn’t connect to the DB because access was denied… The user I was using was root, so its not possible for it to be denied.