powered by Jive Software

Admin password recovery fails

version openfire-3.6.3-1.i386.rpm

os: centos 5.2

database: mysql

I shut down the machine then re-start the machine, all the previous password for all the users not working any more

this situation happen before on my previous installation on another machine.

Search the forum, based on the previous posts,

I tried to re-set the admin password,

here is what I tried:

  1. edit /opt/openfire/conf/openfire.xml

change true to false

then /etc/init.d/openfire restart

it go through the installation again, and reset the “admin” password as “admin”

after finished the installation, the new password doesn't work for login [http://ipaddress:9090/](http://ipaddress:9090/) as user "admin"

but if I use spark to use “admin”, “admin”, the spark allows “admin” login

strange.

  1. then tried to go to mysql database

update openfire.ofUser set plainPassword = ‘admin’, encryptedPassword = null where username = ‘admin’

then restart the openfire service,

Here is another situation, I tried to install the openfire previous version before,

If I use mysqladmin to backup mysql database, and load the backup openfire database into another backup openfire server,

all the user passwords don’t work any more.

why ?

Is this idiotic ?

  1. If restart the machine, all the user password not working

  2. if backup mysql database, move to another standby openfire server, all the user password not working.

  3. If I changed the password for any user, including admin,

every time the encrypted password always different, even though the password still the same.

mysql database: select * from openfire.ofUser

  1. password though spark to server and admin page to server are different ?

well, seems different

after reset password by re-install openfire, spark can login, but not the admin page

well, very frustrating.

Hi,

I just tried the tip in <http://www.igniterealtime.org/community/thread/35034> and it seemed to work for me. Hope that helps.