Admin password

Admin password for Openfire console stopped working. I tried the xml edit method to reset but this does not work. It asks for the old password when you set the new password so this is not going to work.

Any ideas for getting into the console?

Maybe this thread helps:

However, admin password is now stored in database, not longer in openfire.xml file. You could change it in database directly (if you are using an external database) or rerun setup, as described in the thread above.

Which version of Openfire are you using?

When using 3.5.2 or older:

Just an strange idea, but maybe you are using an weak password and your admin account was hacked? Since 3.6.0 there is an (simple) protection against brute force attacks. But before that it was easy to run an brute force or dictionary attack.

In any case, you should use secure passwords. I’m mostly using random generated passwords with lower case and upper case letters and digits with 10 or more digits.

Since you can upload plugin using admin console, an attacker who got access to it could execute arbitrary code.

Thanks. I agree with what you say about passwords.

Unfortunately the method of editing the xml did not work. Is there another way.

version 3.6

What database are you using?

I have the same problem after 3.5.2->3.6.0a upgrade. My DB is PostgreSQL.

I’v tried changing admin password in the SQL console, but it didn’t help.

I’ve found the solution. Your table ofProperty should have somthing like:

admin.authorizedJIDs |,

I had ‘akornilov’ only.

I tried putting in various but still does not work.

I am using the embedded dbase and Openfire ver3.6.

What puzzles me is that when you go through the dummy reinstall after editing the xml file it asks you for the existing admin password. If there is a problem with this it will not accept the new password below it (although there is no error message)… If you don’t put something in the current password input the screen crashes.

From reading various posts it seems that admin unames & pwds can suddenly stop working with Openfire. Is there any surefire way of recovering admin access?

If you are using the embedded database it is hard at best to do any recovery from any error. Try to find gui tools for the database and fix the account. If this is not possible it may be time to start from scratch using a better database solution such as MySQL which is free for just about any OS including windows. It also has an axcellent GUI tool for managing the database.