powered by Jive Software

Admin-Port is created with huge delay (>5 hours)

Hi folks,

I have installed openfire on my Debian 5.0 system and have
problems with the creation of TCP-Ports. Whenever I start
openfire it creates the admin Ports with a huge delay.

/var/log/openfire shows the following for the last two server
startups:


2009.05.13** 01:05:56** Openfire 3.6.4 [May 13, 2009 1:05:56 AM]
2009.05.13** 05:34:25** Admin console listening at:
http://myDomain:9090
https://myDomain:9091
2009.05.13 05:34:25 Started server (unencrypted) socket on port: 5269
2009.05.13 05:34:25 Started plain (unencrypted) socket on port: 5222
2009.05.13 05:34:25 Started SSL (encrypted) socket on port: 5223

2009.05.14 23:24:13 Publish-Subscribe domain: pubsub.myDomain
2009.05.14 23:24:13 Multi User Chat domain: conference.myDomain
2009.05.14 23:24:15 Openfire 3.6.4 [May 14, 2009 11:24:15 PM]
2009.05.15 08:31:27 Admin console listening at:
http://myDomain:9090
https://myDomain:9091
2009.05.15 08:31:27 Started server (unencrypted) socket on port: 5269
2009.05.15 08:31:27 Started plain (unencrypted) socket on port: 5222
2009.05.15 08:31:27 Started SSL (encrypted) socket on port: 5223
2009.05.15 23:58:12 Started SSL (encrypted) socket on port: 5223

As you can see, the delay is bigger than 5 hours.
I have not the slightest idea why this happens. Openfire does
not create any significant debug information. Moreover Debian does
not log any error.

I have configured Openfire to use MySQL. Suns Java JRE is installed
too - not openjdk. Debian is running with kernel 2.6.28.4 on an
OVH RPS (Real Private Server), i.e. the hard drive of the server
is accessed via NFS and located on an other server.

Hopefully one of you can give me a hint what causes this behaviour.
Tips to debug openfire on the server are appreciated to :slight_smile:

Thanks in advance
phiL

Hi,

please read JVM Settings and Debugging and get some thread dumps while Openfire takes so long to start.

LG

Hello,

Try please the following change: open the file $JAVA_HOME/jre/lib/security/java.security, locate ‘securerandom.source’ property. It should be like:

securerandom.source=file:/dev/urandom

Change it to

securerandom.source=file:///dev/urandom

I have the probelm with long time WebLogic starting in Fedora Linux: WL spent a significant time to bind SSL ports and this change helped me. Now I have this change on all my Linux boxes

Regards

Segey