powered by Jive Software

Administrators are lost on restart

On Centos I am running Openfire verion 3.6.3 with mysql as the database and with Active Directory authenication. This is a new install. The install goes fine, at the end the install asks me to enter the openfire administrators. I enter a few active directory users. I finish the setup and I am able to login through the admin console with one of the active directory users I just entered and make the configurations that I want to make.

Users log in, chat with each other, groups that I set up are working and all is right with the world.

The problem comes when I restart the openfire service and the administrators can’t login to the admin console. I go back to the configuration file, enable the setup to start the configuration again, skip to the end of the setup part and enter the administrators again. Log back into the admin console and everything is still configured. But if I restart the service the administrators can’t log in again.

I’m a novice at mysql, does anyone have any suggestions or a direction I should be heading for to solve this problem? Thanks in advance.

check the database to see if the admins are still listed there. if they are you are have some communication issue between the service and the database.

It doesn’t look like the administrators are in the db…

What table did you look in?

ofgroupuser, field name administrator. There is no data in that table.

I have even tried connecting to the DB as root in the chance there was some permissions issue in the db but still no luck…

One more thing. If I try and skip adding users and just try and change “admin” password I get an error that says to check the logs. The logs say “org.jivesoftware.openfire.user.UserNotFoundException: Username admin not found.” If I just skip that step on the “setup” page and don’t add any users, I can login with the AD user I set up the first go around.

the admin users for an LDAP setup are stored in the ofproperty table, as is most of the other settings.