powered by Jive Software

After update 3.4.3 --> 3.4.4 - Server does not support VCards. Unable to save your VCard

After update 3.4.3 --> 3.4.4 - When you try to update Avatar you get the following error. Server does not support VCards. Unable to save your VCard. I went back to 3.4.3 and it works fine.

Are you using LDAP? If you are did you enable the feature to allow vCards for LDAP?

We are using LDAP / Active Directory. Where do you enable the feature to allow vCards for LDAP?

Login to the openfire admin page. Go to system properties. Make sure ldap.override.avatar is set to true. I find it odd that the avatars worked in 3.4.3 with AD because it is not supported unless you are running a third party plugin which no longer functions in current versions.

ldap.override.avatar is set to true. We do currently have a vcard plugin. This is the error message in the log

java.lang.UnsupportedOperationException: LdapVCardProvider: Invalid vcard changes.

at org.jivesoftware.openfire.ldap.LdapVCardProvider.updateVCard(LdapVCardProvider. java:323)

at org.jivesoftware.openfire.vcard.VCardManager.setVCard(VCardManager.java:132)

at org.jivesoftware.openfire.handler.IQvCardHandler.handleIQ(IQvCardHandler.java:8 2)

at org.jivesoftware.openfire.handler.IQHandler.process(IQHandler.java:48)

at org.jivesoftware.openfire.IQRouter.handle(IQRouter.java:348)

at org.jivesoftware.openfire.IQRouter.route(IQRouter.java:100)

at org.jivesoftware.openfire.spi.PacketRouterImpl.route(PacketRouterImpl.java:67)

at org.jivesoftware.openfire.net.StanzaHandler.processIQ(StanzaHandler.java:303)

at org.jivesoftware.openfire.net.ClientStanzaHandler.processIQ(ClientStanzaHandler .java:78)

at org.jivesoftware.openfire.net.StanzaHandler.process(StanzaHandler.java:268)

at org.jivesoftware.openfire.net.StanzaHandler.process(StanzaHandler.java:167)

at org.jivesoftware.openfire.nio.ConnectionHandler.messageReceived(ConnectionHandl er.java:132)

You need to be on Openfire 3.4.4 and no plugin to make vCards work.

I remove the plugin and installed 3.4.5, but I still get the same error???

So you are now at 3.4.5 of openfire, and have that property set to true and removed the plugin and its directory form the plugins folder? If that is all yes maybe you could try to rerun the setup for openfire again. to do that you need to stop the openfire server, then edit the openfire.xml to change this <setup>true</setup> to <setup>false</setup>. During the setup process there is a screen to map LDAP attributes. On this screen there is a checkbox to enable LDAP vCard Avatars. Be sure to check the box.

I had the same issue. I upgraded to 3.4.5 and then you couldn’t change avatars. Also the ldap.override.avatar was missing. So I ran the wizard for the LDAP connection and it appeared again but set to false. I changed it to True and now I can change the avatars with no errors.