powered by Jive Software

After update we have a big problems!

Hello,

I have been using your software for many years. Although I stopped on the client version 2_6_3, and I don’t remember the server, anyway, I decided to upgrade the client and server to the latest version.
This is where strange things started to happen … First of all, some users have a problem that they cannot write to other users, if they choose their name, a white window pops up and they neither receive messages from these people, nor can they send themselves . The only solution is then to kick the user out of the database and put him back.
The second problem is the problem when changing the password, it can not be done … We enter the password and select the item update, nothing happens, the only option is to change it through the admin panel.
I am asking for help because I would not like to change this program because we are all used to it.

I’m sorry to hear about those problems. What version of both Openfire and Spark are you using exactly?

Can you review the log files of both, and see if there are any relevant entries in them?

Yesterday I noticed a new version of the client, so I installed it right away and the problem stopped for now… But still, we can’t change the password from the client.
As for the logs, I looked through them and there was nothing special there. I am currently using “Openfire 4.6.0” and “Spark 2.9.3”.

Good to hear that you were able to fix most of the issues.

With the latest version of Spark and Openfire, I can change the password of a user using the ‘Preferences’ dialog without a problem.

Are you by any chance using an LDAP or AD (or otherwise ‘read-only’) user / authentication provider? In that case, passwords cannot be changed. That, however, has always been the case for these integrations.

All the time I only have default selected, but when I want to select LDAP both are selected and it cannot be saved.

. The question is whether it is possible to connect the spark to own AD? If so, I would like to use this option, but I don’t know how.

This looks like a bug, although i’m not sure if this is a proper option to change Profile setting on the fly and not on initial setup.

Yes, but this is not a trivial task and from what i’ve seen in the forums many fail to implement it. You can find a few guides in the forums looking for “SSO”.
One of the recent ones:


Or this one in video format:

Btw, check in Admin Console > Server Settings > Registration & Login menu:
image

And for the logs, it would be better if you can provide them for us to check and make sure there is nothing related to this problem. It is best to delete current logs before reproducing the problem. Logs are stored at C:\Users\User\AppData\Roaming\Spark\logs. Exit Spark, delete all logs, run Spark and try to change the password. Zip all the logs and attach here. You can first go through them and replace usernames or domain name, if this is confidential.

Hello,
I managed to connect my Spark to the domain, I’m proud of myself. Thank you for your help! But I have one more question. Namely, do you have an .msi file to update the client on multiple computers at once? It would be very useful to me.

PS.: I’m sorry but unfortunately I can’t share our logs.

Spark is not available in MSI format.
You can make MSI yourself via the program https://www.exemsi.com/

or here is a link how you can install the program with a script using group policies in the domain.

IF EXIST "C:\drv\Spark_2.9.3.txt" GOTO END
taskkill /F /IM Spark.exe
mkdir c:\drv
"C:\Program Files (x86)\Spark\uninstall.exe" -q
rmdir "C:\Program Files (x86)\Spark" /s /q
robocopy "\\srv-it\app\Spark2.9.3" "C:\drv\Spark2.9.3" /R:5 /W:5 /MT
start /wait C:\drv\Spark2.9.3\spark_2_9_3.exe -q
copy /Y nul "C:\drv\Spark_2.9.3.txt"
:END

Hello

We want to change Spark’s login to domain name. Below the first tab of client configuration:


The second looks like this:

With this configuration we are not able to log in to Spark.

An error like the one below will appear:
obraz


After checking the option Use Direct TLS methods or Disable certificate hostname verification (not recommended) , we can log in.

We would like the option Disable certificate hostname verification (not recommended) to be checked. Please help, what do we have to do to make the login work with these settings?

I’m guessing in the last sentence you meant to not be checked. When this option is not selected Spark is comparing the domain name in certificate that your server is presenting and the domain name you have provided on login screen. If they don’t match, this can mean that your user is connecting to a wrong server, so it warns by showing this error. To check what domain name is used in certificate in Admin Console of Openfire go to Server > TLS/SSL Certificates menu, click on a first Manage Store Contents link. Here you should see a certificate your server is using.

This is mine:


It says my server’s domain is wroot.
When i use wroot in Spark as domain it doesn’t show such error and i don’t have to select that setting as domain name in both places matches. This works in my case as this is my test server and both Openfire and Spark are on the same PC and wroot is actually my PC’s name. In production you would have to use DNS names so all PCs in the network can understand where they should go when you put some name in Domain field.