After upgrade Hazelcast Clustering Plugin to 2.1.0. the clustering does not work

Hi, everyone.

Just yesterday I upgraded “Hazelcast Clustering Plugin” from version 2.0 to 2.1.0. After this clustering was automatically disabled. When I try to enable it back I receive error message:

Failed to start or join an existing cluster. Check the error log for more information.

There are these lines in my error log:

org.jivesoftware.openfire.plugin.util.cache.ClusteredCacheFactory - Unable to start clustering - continuing in local mode

com.hazelcast.config.InvalidConfigurationException: cvc-complex-type.2.4.b: The content of element ‘symmetric-encryption’ is not complete. One of ‘{“”:algorithm, “”:salt, “”:password, “”:iteration-count}’ is expected.

at com.hazelcast.config.AbstractXmlConfigHelper.schemaValidation(AbstractXmlConfig

at com.hazelcast.config.XmlConfigBuilder.parseAndBuildConfig( :211)

At the same time the line from xml configuration file about “symmetric-encryption” looks like:

I think there are two possibilities. The first one - I did upgrade in incorrect way and it corrupted my installation. (It is possible because I just pressed upgrade at the “Plugins” page). The second one - there is a mistake witch demands assigning “algorithm”, “salt”, “password”, “iteration-count” parameteres even the whole item “symmetric-encryption” is disabled.

Then I removed those plugins, reinstalled them several times but no luck - at the moment of enabling clustering I receive the same error message. That is why I wrote this message. I beleive there could be some mistake in new version of Hazelcast Clustering Plugin.

I am wrong?

I did clear install of Hazelcast Clustering Plugin and I still receive the same error and I’ve got very similar things in error.log file.

So I suppose something has been changed in Hazelcast and “default” hazelcast-cache-config.xml witch worked with Hazelcast Clustering Plugin 2.0, does not work with Hazelcast Clustering Plugin 2.1.0.

Hi Roman -

Thanks for the report, agree it looks like the configuration XML has changed slightly - apologies we missed this in our initial shakedown. Will investigate further and report back shortly.



Submitted PR #278 to address this issue; build version of the fixed Hazelcast plugin will be 2.1.1.

I have just installed new version Hazelcast Clustering Plugin 2.1.1. It works perfectly. Great and quite fast job. Thank you.