powered by Jive Software

Aim transport configuration for wildfire 2.5.1 on XP

Hi,

I’'m completely new to this whole chat thing and I have to setup a Jabber server with no prior experience in how this thing should work.

I’'ve got Wildfire 2.5.1 installed on XP SP2 with the following AIM gateway components installed:

Python 2.3.5

PyAIMt 0.6

pycrypto 2.0 for Python 2.3

pyOpenSSL 0.6 for Python 2.3

Twisted 1.3.0 for Python 2.3

The only changes I’‘ve made to PyAIM’‘s config file is to change the jid and the secret to reflect my Wildfire settings. I start the gateway with “python main.py” from the gateway’'s src dir and seems to start OK. But when I start up Wildfire and view the Server Sessions or Component Sessions, there are no connected remote servers or connected external components.

I’‘ve tried searching the forum for someone who’‘s tried this but haven’‘t found anything that’'s been helpful. If anyone can send a link to a set of useful steps it would be greatly appreciated.

Any help would be welcome.

Thanks!

read though it you will see the useful info (I guess)

http://www.jivesoftware.org/community/thread.jspa?messageID=116061&#116061

Another thing you are likely to need to set is the port over which PyAIM connects. (10015 by default under Wildfire… but you also have to make sure you have enabled under External Components in your wildfire admin console. If that doesn’‘t work, you may want to try to start up PyAIM in debug mode (python main.py -D) and see if that tells you what’'s going on. Also note that there are newer versions available that fix a lot of bugs in the older versions. =)