powered by Jive Software

AIM "you have attempted to connect too many times..."

After upgrading to 1.0.2, i get the following error in spark:

“You have connected too many times in too short of a time frame. Please wait around 15 minutes before trying again.”

This error is coming from the AIM gateway.

yes, i tried not logging in for several hours and still the error. Tried deleting my registration and readding but still the same error. Even disabled the aim transport for a few hours and that did not help.

Thanks

Well, the thing about that 15 minute message is… it’‘s kind of a lie. ;D AIM is very petulant about that error. If you connect, and then try connecting again immediately, it bumps the time. I connected three times in a row one time and couldn’‘t reconnect for 3 hours. =( What’‘s worse? Every time you try later on to see if you can reconnect, if enough time hasn’‘t passed (that you don’‘t really know how long of a time you have to go), your time gets bumped even more. It’‘s really irritating. Especially for me when I’'m testing things. I have to log out and in a lot just to get things tested. I got to a point where I created accounts for all my pets. =/

well i noticed in the logs that there are several oscar connections when i login to spark. they are all exactly the same second. seems there is a problem logging in. i logged in to aim using pidgin just fine on the account that was apparently locked out using the gateway.

here is an example from the log. i restarted the aim transport and then opened spark. here is the result:

2007.05.18 18:12:27 OSCAR connection to 205.188.8.74:5190

2007.05.18 18:12:27 OSCAR connection to 205.188.8.73:5190

2007.05.18 18:12:28 OSCAR connection to 205.188.8.74:5190

2007.05.18 18:12:28 OSCAR connection to 205.188.8.72:5190

2007.05.18 18:12:28 OSCAR connection to 205.188.8.74:5190

2007.05.18 18:12:29 OSCAR connection to 205.188.8.73:5190

2007.05.18 18:12:29 OSCAR connection to 205.188.8.72:5190

probably has something to do with the new autoreconnect feature. i noticed in 1.0.1 that when i first opened spark, it said i have automatically been disconnected from AIM. I would have to manually tell spark to login to the AIM transport but all worked well after that.

Message was edited by: snowman386

Not sure what to tell you, I can not duplicate that.

well could i send you a packet capture or something?

Do you have debugging enabled? The debug log might be the best.

Seems it was a problem with spark itself. I tried logging in on another machine and it worked fine. Removed spark, cleaned out everything, and reinstalled and all appears to work great now.

Yikes! Well thanks for letting me know!! =)