powered by Jive Software

Always bind on loopback interface

WebAdmin list properly on 192.168.0.254 but other services doesnt.

I tried to edit the /etc/hosts file, but didnt fix the problem.

Configuration: SSL is on, MySQL is the DB,

Process full line:

ps -Af | grep wildfire

bozo 20348 1 3 05:17 pts/1 00:00:15 /opt/wildfire/jre/bin/java -server -Dinstall4j.jvmDir=/opt/wil dfire/jre -Dinstall4j.appDir=/opt/wildfire -Dexe4j.moduleName=/opt/wildfire/bin/wildfire -classpath /opt/wildf ire/.install4j/i4jruntime.jar:/opt/wildfire/lib/activation.jar:/opt/wildfire/li b/bouncycastle.jar:/opt/wildfir e/lib/commons-el.jar:/opt/wildfire/lib/hsqldb.jar:/opt/wildfire/lib/hsqldbutil. jar:/opt/wildfire/lib/jasper-co mpiler.jar:/opt/wildfire/lib/jasper-runtime.jar:/opt/wildfire/lib/jdic.jar:/opt /wildfire/lib/jtds.jar:/opt/wil dfire/lib/mail.jar:/opt/wildfire/lib/mysql.jar:/opt/wildfire/lib/postgres.jar:/ opt/wildfire/lib/servlet.jar:/o pt/wildfire/lib/startup.jar:/opt/wildfire/lib/wildfire.jar com.install4j.runtime.Launcher start org.jivesoftwa re.wildfire.starter.ServerStarter false false /opt/wildfire/bin/…/logs/stderror.log /opt/wildfire/bin/…/logs /stdoutt.log true true false true true 0 0 20 20 Arial 0,0,0 8 500 version 2.6.2 20 40 Arial 0,0,0 8 500 -1 -DwildfireHome=/opt/wildfire -Dwildfire.lib.dir=/opt/wildfire/lib start

bozo 20484 1 86 05:24 pts/0 00:00:09 /opt/wildfire/jre/bin/java -server -Dinstall4j.jvmDir=/opt/wil dfire/jre -Dinstall4j.appDir=/opt/wildfire -Dexe4j.moduleName=/opt/wildfire/bin/wildfire -classpath /opt/wildf ire/.install4j/i4jruntime.jar:/opt/wildfire/lib/activation.jar:/opt/wildfire/li b/bouncycastle.jar:/opt/wildfir e/lib/commons-el.jar:/opt/wildfire/lib/hsqldb.jar:/opt/wildfire/lib/hsqldbutil. jar:/opt/wildfire/lib/jasper-co mpiler.jar:/opt/wildfire/lib/jasper-runtime.jar:/opt/wildfire/lib/jdic.jar:/opt /wildfire/lib/jtds.jar:/opt/wil dfire/lib/mail.jar:/opt/wildfire/lib/mysql.jar:/opt/wildfire/lib/postgres.jar:/ opt/wildfire/lib/servlet.jar:/o pt/wildfire/lib/startup.jar:/opt/wildfire/lib/wildfire.jar com.install4j.runtime.Launcher start org.jivesoftwa re.wildfire.starter.ServerStarter false false /opt/wildfire/bin/…/logs/stderror.log /opt/wildfire/bin/…/logs /stdoutt.log true true false true true 0 0 20 20 Arial 0,0,0 8 500 version 2.6.2 20 40 Arial 0,0,0 8 500 -1 -DwildfireHome=/opt/wildfire -Dwildfire.lib.dir=/opt/wildfire/lib start

bozo 20512 6916 0 05:24 pts/0 00:00:00 grep wildfire

In wildfire.xml:

Log:

2006.05.14 05:08:51 Stopping server

2006.05.14 05:17:12 Loading plugin admin

2006.05.14 05:17:18 Loading plugin search

2006.05.14 05:17:10 Started plain (unencrypted) socket on port: 5222

2006.05.14 05:17:12 Started SSL (encrypted) socket on port: 5223

2006.05.14 05:17:12 Publish-Subscribe domain: pubsub.XXXXX.org

2006.05.14 05:17:12 Multi User Chat domain: conference.XXXXX.org

2006.05.14 05:17:12 Wildfire 2.6.2

WebAdmin:

1: IP:Port, Security: 127.0.0.1:5222, NORMAL

Domain Name(s): XXXXX.org

2: IP:Port, Security: 127.0.0.1:5223, TLS (SSL)

Domain Name(s): XXXXX.org

Version: Wildfire 2.6.2

Wildfire Home: /opt/wildfire

Server Name: XXXXX.org

JVM Version and Vendor: 1.5.0_06 Sun Microsystems Inc. – Java HotSpot™ Server VM

Appserver: Jetty/5.1.x

OS / Hardware: Linux / i386

NOTE:

It does listen to the 192.168.0.254 but admin / log doesnt not reflect that.

Hi,

is it just a display problem within the web gui? I can see a similar behavior where 127.0.0.1 is displayed while Wifi binds to all interfaces. Is it possible that your xmpp.domain name XXXXX.com does locally resolve to 127.0.0.1? It’'s usually the 1st line in /etc/hosts which reads 127.0.0.1 localhost myserver.domain.com and if your resolver first checks the hosts file then it will never check the DNS server.

Would you please post the contents of your /etc/hosts file and the output of netstat -an|grep -E “9090|5222|5223|7777”

LG