powered by Jive Software

Asking Again! Spark Phone Delay

I asked this question back a few weeks ago an no one answered so I am not sure if it is an isolated issue or not. I like using spark and want to move over to it as my primary softphone.

The problem I am having is that when I make a call. The phone dials says connected and it takes about 7 seconds before I can here the party on the other end. If I call my voicemail the same thing happens. It connects and it takes about 7 seconds before I can hear anything. So I only hear the last word about entering my passcode.

Any ideas, other softphones dont have this problem so I am sure it is related to this or openfire.

Thanks in advance for the help!

Hello,

This delay in SIP Phone is due JMF delays.

For Jingle calls the delay is bigger due negotiations + JMF.

Some JMF users related that if you desable netbios and extra unused network protocols in windows, this delay will be reduced.

The regular delay for SIP Phone is 5 secs (max) and 3 secs in average.

For Jingle the delays is around 7 secs in average and 10 max.

Let me know in which scenario are you using Spark Phone. Which SIP Server, where is the server etc…

Best Regards and thanks for the interest in Spark Phone,

Thiago

Thanks for getting back to me. 7-10 seconds is exactly what I am getting. Mostly about 7 though.

I am running the latest asterisk 1.4 with FreePBX.

The server is located on my LAN.

The Spark clients are on Windows XP

I am using the elastix prebult at this time (but the same thing was happening with Trixbox). I am of course running the PBX on Linux centos 5 and openfire on the same machine.

I hope this is what you were asking me for.

Let me know what I can do to fix this.

Ill patiently wait on your reply.

R

I dont beleive I need the Jingle cleint as I am using a PBX, so we can do person to person calling over the PBX. If I drop the Jingle client plugin with that fix the problem. I want to be clear also that the calls that are delaying are on my PBX and not from the PC to PC calls. Thanks!

Well, that’s really weird as for SIP calls the average is 3 seconds, and 5 seconds maximum.

Are you trying to make a call for a PSTN number or another SIP account in the same SIP Server?

Some SIP providers take between 5 and 6 secs to complete your call.

Cheers,

Thiago

Ok I believe it is a problem with just this machine. I went to another machine and tried it and it appears to have just a few second delay as appossed to a long delay. The weird thing is I go to my laptop and try it that is on a wireless connection and it works, but my desktop in my office has the delay.

So it is my machine I believe, I am going to check another mahcine also. I am not sure what do you think it could be?

Thanks for your replies.

lefty

Can you please try to disable netbioes over tcp option in windows network settings?

Cheers,

Thiago

Thiago, I will try that when I reboot next. That machine cant be shut down right now but when it can be I will try that first, then post the results. Thanks

I looked and I dont have netbios over TCP enabled anyway. I tried removing all protocols except TCP and still nothing fixed it.

I dont know if this can tell anyting, when I open spark, I put a phone number in and click call. The box opens saying outgoing call blah blah it takes exactly 10 seconds to connect.

When I disabled the other protocols, it went for about 7 seconds, then I would hear the call for a split second, then it would take a few seconds and the call window would open and I could hear the call.

Any thoughts?