powered by Jive Software

Asterisk and Wildfire on the same machine?

I (perhaps stupidly) installed Wildfire on a fresh Asterisk@Home 2.5 system. They seem to coexist fine, but I am not getting the notifications in spark.

Is it bad to run Wildfire on an Asterisk box?

I get:

2006.02.20 14:56:27 Successfully logged in

2006.02.20 14:56:27 Determined Asterisk version: Asterisk 1.0

It is version 1.2.4…Could that have something to do with no seeum notifications?

I see the answer to not seeing the notifications. Asterisk 1.2.4 is too new.

I still am wondering about mutihoming Asterisk and Wildfire.

H Robert,

it’'s no problem to run Wifi and Asterisk on the same server. But it seems that one should always use the DNS names and not 127.0.0.1 for communication between Asterisk-IM and Asterisk.

LG

Hi

You can take a look at working setup. It is in a VMware image. It has all parts configured and working. But it uses Coccinella client. Spark has some problems that I could not figure out. Coccinella gives a strange message once in a while, but in general it works well.

Here is info on demo setup http://serge.mankovski.com/voip/asterisk-and-jabber

Cheers

Serge

I am running asterisk and Wildfire on a machine behind a nat firewall. Internal interface is 192.168.0.1/external is 69.160.170.216/domain name is admin.inetws.net. I have tried inputting 127.0.0.1, 192.168.0.1, admin.inetws.net, 69.160.170.216 in the address field for Asterisk-IM. Asterisk and wildfire logs show a successful login. Wildfire logs show a timeout waiting for a response. Here is the odd thing if I run telnet localhost 5038 from the machine running both I can successfully access the Asterisk manager. Any thoughts?

Hi Kevin,

is it possible that Asterisk sends the response to your external interface and there it get’'s dropped? Maybe it helps to add a line to /etc/hosts like:

192.168.0.1 admin.inetws.net

LG

Thanks for the thoughts. I have since setup a local DNS entry for admin.inetws.net so that machines on the local lan see its ip as 192.168.0.1. The thing that I still am confused about is why it seems that you must use a fully qualified domain name for this particular module. Most of the other apps (Java and otherwise) running on this server are happy if I put in 127.0.0.1, 192.168.0.1, localhost, or admin.inetws.net including a direct telnet to the Asterisk manager from admin.inetws.net. Anyway following is a result of a dig and traceroute run directly from a shell on admin.inetws.net

$ dig admin.inetws.net

; <<>> DiG 9.2.1 <<>> admin.inetws.net

;; global options: printcmd

;; Got answer:

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16031

;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:

;admin.inetws.net. IN A

;; ANSWER SECTION:

admin.inetws.net. 38400 IN A 192.168.0.1

;; AUTHORITY SECTION:

inetws.net. 38400 IN NS admin.inetws.net.

;; Query time: 4 msec

;; SERVER: 192.168.0.1#53(192.168.0.1)

;; WHEN: Tue Mar 14 23:44:29 2006

;; MSG SIZE rcvd: 64

$ traceroute admin.inetws.net

traceroute to admin.inetws.net (192.168.0.1), 30 hops max, 38 byte packets

1 192.168.0.1 (192.168.0.1) 0.252 ms 0.231 ms 0.162 ms

$