powered by Jive Software

Asterisk-IM 1.1 Beta

Hi everyone,

Here is the beta version 1.1. It will require that you build a new version of wildfire from the subversion trunk. It also requires that you are running Asterisk 1.2 or newer.

There have been many improvements:

  • Fixed MANY presence issues!!!

  • Taking advantage of new events from asterisk 1.2 (ie the Dial event).

  • Taking advantage of new features of the asterisk-java api.

  • Better upgrade framework, based off the new upgrade framework in the upcoming wildfire release.

  • Improved caller id information.

  • Fixed many admin tool mapping page bugs.

  • Greatly simplified - Removed hibernate, Manager connection pooling.

  • Smaller Download
    asterisk-im.jar (376245 Bytes)

Hi Andrew,

what does “subversion trunk” mean? Is the nightly build fine or where may one find the right subversion trunk?

LG

Is the nightly build fine

Yep! The nightly builds of Wildfire will work great.

Regards,

Matt

I should have clarified to say that the nightly builds or latest SVN code are required since this version of Asterisk-IM relies on Wildfire 2.6. We’'ll also be releasing a new version of Spark that has Asterisk-IM improvements:

  • Working caller ID.

  • Better notification UI for incoming calls.

Regards,

Matt

Matt,

Tried to run wildfire_2006-03-25.tar.gz along with the Asterisk-IM 1.1 Beta. I still have users that get stuck “on the phone” after receiving queue calls and dialing agentcallbacklogin.

Ken

Ken,

Thanks for the bug report. I’‘m assuming that events are getting generated in ways that we wouldn’'t expect. Are the users still stuck on “on the phone” after a few minutes have passed?

Can you provide any more detail about how we can reproduce this? I don’‘t think we’'ve tried out queue calls yet.

Regards,

Matt

Here’‘s an urgent request to somehow make this available to a poor Windows user who can’'t build a nightly.

Would it be possible for someone to build a version of Wildfire for windows that will work with this beta version 1.1 of the plugin? I’'d really like to get some of these issues resolved.

Hi Tony,

there are source builds and normal builds, there’'s no need to build one. If you need an installer instead of a zip file then please wait for Wifi 2.6, it should be released the 6th April.

LG

andrew;

restarting asterisk while the wildfire server is still running causes an endless loop of failed connection attempts. so far this is only corrected by restarting wildfire, (reloading the plugin might do it too.).

hello!

just tested wildfire 2.6 with im 1.1

the caller id function works ok

the dial function stopped working with trillian

is there a way to monitor who is calling in the zap channels? or maybe who is calling in a queue or ring group?

here is the log when i try to call with trillian:

2006.04.12 16:21:44 [org.jivesoftware.phone.asterisk.AsteriskPhoneManager.dial(AsteriskPhoneManager .java:340)

] 1

java.lang.ArrayIndexOutOfBoundsException: 1

at org.jivesoftware.phone.asterisk.AsteriskPhoneManager.dial(AsteriskPhoneManager. java:329)

at org.jivesoftware.phone.asterisk.AsteriskPhoneManager.originate(AsteriskPhoneMan ager.java:138)

at org.jivesoftware.phone.PacketHandler.handleDial(PacketHandler.java:81)

at org.jivesoftware.phone.PacketHandler.processPacket(PacketHandler.java:47)

at org.jivesoftware.phone.asterisk.AsteriskPlugin.processPacket(AsteriskPlugin.jav a:222)

at org.jivesoftware.wildfire.component.InternalComponentManager$RoutableComponent. process(InternalComponentManager.java:364)

at org.jivesoftware.wildfire.IQRouter.handle(IQRouter.java:215)

at org.jivesoftware.wildfire.IQRouter.route(IQRouter.java:96)

at org.jivesoftware.wildfire.PacketRouter.route(PacketRouter.java:65)

at org.jivesoftware.wildfire.net.SocketReader.processIQ(SocketReader.java:396)

at org.jivesoftware.wildfire.net.ClientSocketReader.processIQ(ClientSocketReader.j ava:50)

at org.jivesoftware.wildfire.net.SocketReader.readStream(SocketReader.java:264)

at org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:119)

at java.lang.Thread.run(Unknown Source)

Alex-

See my post here: http://www.jivesoftware.org/community/thread.jspa?threadID=19136&tstart=0

There is a bug in the asterisk-im module that causes dial to fail if you don’'t specify dial variables. Quick fix is to just add a junk variable to the config (A=B), or you can apply the simple source code patch that I posted in the thread and build your own jar.

I haven’‘t seen any responses from the developer about the patch, so use at your own risk It’'s been working fine for me, though.

  • K