powered by Jive Software

Asterisk IM not mapping to SIP phones

So I have installed Asterisk and Openfire and everything works fine so far, EXCEPT! for this ont thing drivng me nuts. I can not send text messages from the Bria for iPhone app to another phone or computer. When I look at everything it looks like the Asterisk IM plugin is not mapping the phones correctly. These are the errors I get.

In OpenFire Logs:

2012.03.19 12:56:44 org.asteriskjava.manager.internal.EventBuilderImpl - Unable to set property ‘channeltype’ to ‘SIP’ on org.asteriskjava.manager.event.PeerStatusEvent: no setter
2012.03.19 12:56:44 org.asteriskjava.manager.internal.EventBuilderImpl - Unable to set property ‘hint’ to ‘SIP/2000’ on org.asteriskjava.manager.event.ExtensionStatusEvent: no setter
2012.03.19 12:57:15 org.asteriskjava.manager.internal.EventBuilderImpl - Unable to set property ‘channeltype’ to ‘SIP’ on org.asteriskjava.manager.event.PeerStatusEvent: no setter
2012.03.19 12:57:15 org.asteriskjava.manager.internal.EventBuilderImpl - Unable to set property ‘hint’ to ‘SIP/2001’ on org.asteriskjava.manager.event.ExtensionStatusEvent: no setter
2012.03.19 12:57:16 org.asteriskjava.manager.internal.EventBuilderImpl - Unable to set property ‘channeltype’ to ‘SIP’ on org.asteriskjava.manager.event.PeerStatusEvent: no setter
2012.03.19 12:57:16 org.asteriskjava.manager.internal.EventBuilderImpl - Unable to set property ‘address’ to ‘198.228.235.5:36886’ on org.asteriskjava.manager.event.PeerStatusEvent: no setter
2012.03.19 12:57:19 org.asteriskjava.manager.internal.EventBuilderImpl - Unable to set property ‘channeltype’ to ‘SIP’ on org.asteriskjava.manager.event.PeerStatusEvent: no setter
2012.03.19 12:57:19 org.asteriskjava.manager.internal.EventBuilderImpl - Unable to set property ‘hint’ to ‘SIP/2000’ on org.asteriskjava.manager.event.ExtensionStatusEvent: no setter

In Asterisk CLI:

WARNING[1284]: chan_sip.c:16298 receive_message: Received message to sip:2001@mydomain.net from “User Name” sip:2000@mydomain.net;tag=aRilkNE0zD4McqwY05ELakD8-IF.SnrT, dropped it…

Content-Type:text/plain

Message: Busy… I’ll IM you later.

Anyone got any Ideas I would love to hear them. My guess is that I have installed this on a machine with Ubuntu 11.10 server and had to use OpenJDK-6-jre because as I am sure alot of you know OracleJava has stripped their clients out of Canonical. I have everything working fine on an old Petium III server before all this, but haven’t got it to work at all with OpenJDK-6 or 7 and is “supposed” to be completely compatible.

Anyway, like i said any help would be great.

Thanks,

Steel

ok I rebuilt the server and i used the real sun-java6-jre and I am still getting this error.

Anyone out there have any idea why?